Bug 1313848 - selecting the Oscap_Proxy throws TypeError as seen from Firebug
Summary: selecting the Oscap_Proxy throws TypeError as seen from Firebug
Keywords:
Status: CLOSED DUPLICATE of bug 1314354
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-02 12:43 UTC by Kedar Bidarkar
Modified: 2019-04-01 20:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-20 09:50:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Kedar Bidarkar 2016-03-02 12:43:08 UTC
Description of problem:

selecting the Oscap_Proxy host throws TypeError as seen from Firebug

Firebug shows the below error when  selecting "Openscap proxy":

TypeError: $(...).indicator_show is not a function
	

...+o:t+"&host_id="+o,toggleErrorText(""),$(e).indicator_show(),$.ajax({type:"post"...


No issues seen in "/var/log/foreman/production.log"

Version-Release number of selected component (if applicable):
Sat6.2.0-Beta-SNAP1

How reproducible:


Steps to Reproduce:
1. configure OSCAP plugin and restart services
2. create a "New Host" and specify the "oscap proxy" to note the above TypeError in FireBug.
3.

Actual results:
Issues seen with selecting the "oscap proxy"

Expected results:
Firebug should throw no issues while selecting the "oscap proxy".

Additional info:

Comment 3 Kedar Bidarkar 2016-03-07 08:51:29 UTC
I do have all the packages installed and openscap feature is visible on the capsule features.

Also openscap-proxy does show the capsule's hostnames from the select box and I see this issue from both firefox and chrome browsers.

Comment 6 Shlomi Zadok 2016-03-14 13:27:04 UTC
https://github.com/theforeman/foreman_openscap/pull/153 is merged

Comment 7 Eric Helms 2016-03-15 17:22:28 UTC

*** This bug has been marked as a duplicate of bug 1314354 ***

Comment 8 Kedar Bidarkar 2016-05-20 09:46:58 UTC
We still see this issue for both firefox and chrome browsers.


POST https://oscap.redhat.com/hostgroups/openscap_proxy_changed 404 (Not Found)send @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:27st.extend.ajax @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:27updateOpenscapProxy @ openscap_proxy-3b847fe7ed27cdc7b6678b9fb3775af368520aa8615c6f83b5958e761dc3f857.js:1onchange @ new:332st.event.trigger @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:26(anonymous function) @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:26st.extend.each @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:15st.fn.st.each @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:15st.fn.extend.trigger @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:26E.triggerChange @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:604E.onSelect @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:605E.selectHighlighted @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:604(anonymous function) @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:604(anonymous function) @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:604st.event.dispatch @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:26g.handle @ application-3c4768bf2dcc5be221d91702179e80d17b33f0c1940ebbf5d423814824814745.js:25


TESTED with sat6.2-snap12.1

Comment 9 Kedar Bidarkar 2016-05-20 09:50:16 UTC

*** This bug has been marked as a duplicate of bug 1314354 ***


Note You need to log in before you can comment on or make changes to this bug.