Bug 1314354 - unable to select oscap XCCDF profile while creating a policy
unable to select oscap XCCDF profile while creating a policy
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Shlomi Zadok
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
: 1313848 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 07:46 EST by Kedar Bidarkar
Modified: 2016-07-27 05:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:25:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14073 None None None 2016-04-22 12:08 EDT

  None (edit)
Description Kedar Bidarkar 2016-03-03 07:46:01 EST
Description of problem:

unable to select oscap XCCDF profile while creating a policy. The "XCCDF Profile" select box is grayed out, which does not allow any value to be selected.

Also Firebug shows the below issue upon selecting the "scap content":

TypeError: $(...).indicator_show is not a function
	

..._content_id"]),t=$(e).attr("data-url");$(e).indicator_show(),$.ajax({data:c,type...

	

Version-Release number of selected component (if applicable):
Sat6.2.0-Beta-SNAP2

How reproducible:


Steps to Reproduce:
1. create an oscap policy to face this issue.
2.
3.

Actual results:
unable to select oscap XCCDF profile while creating a policy.

Expected results:
Should be able to select oscap XCCDF profile while creating a policy.

Additional info:
Comment 3 Shlomi Zadok 2016-03-14 09:27:18 EDT
https://github.com/theforeman/foreman_openscap/pull/153 is merged
Comment 4 Eric Helms 2016-03-15 13:22:28 EDT
*** Bug 1313848 has been marked as a duplicate of this bug. ***
Comment 5 Eric Helms 2016-03-15 13:25:40 EDT
This is currently blocked by https://github.com/theforeman/foreman_openscap/pull/154 but I do not know what Redmine or BZ is associated to the change to set a blocks relationship.
Comment 8 Kedar Bidarkar 2016-03-31 15:08:46 EDT
VERIFIED With sat62-snap6

This issue is no longer seen with snap6
Comment 9 Kedar Bidarkar 2016-05-20 05:50:16 EDT
*** Bug 1313848 has been marked as a duplicate of this bug. ***
Comment 11 errata-xmlrpc 2016-07-27 05:25:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.