This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1313860 - Smart proxy does not start with SYSLOG setting
Smart proxy does not start with SYSLOG setting
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule (Show other bugs)
6.2.0
Unspecified Unspecified
urgent Severity high (vote)
: Beta
: --
Assigned To: Lukas Zapletal
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1313857
  Show dependency treegraph
 
Reported: 2016-03-02 08:16 EST by Lukas Zapletal
Modified: 2016-07-27 05:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:24:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13427 None None None 2016-04-22 11:09 EDT

  None (edit)
Description Lukas Zapletal 2016-03-02 08:16:48 EST
This bug looks like non-blocker, but Foreman Discovery Image relies on this feature and proxy does not start on the image. We need to pull the fix in order to be able to build working fdi.
Comment 3 Bryan Kearney 2016-03-02 10:03:08 EST
Upstream bug assigned to lzap@redhat.com
Comment 4 Bryan Kearney 2016-03-02 10:03:10 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13427 has been closed
-------------
Anonymous
Applied in changeset commit:a838204ef2e21b9c3e89db84894b35a7af059d18.
Comment 6 Sachin Ghai 2016-04-18 08:04:34 EDT
@Lzap: please provide verification steps. I'm assuming foreman-proxy should run on the image. Anything else needs to be tested here ? Please suggest.
Comment 7 Lukas Zapletal 2016-04-18 10:07:55 EDT
Steps: Boot a PXE-less or PXE discovery, login to the image, issue something like

   journalctl -u foreman-proxy

and you should see logs from foreman-proxy process (at least startup logs).
Comment 8 Sachin Ghai 2016-04-20 02:43:06 EDT
Verified with sat6.2 beta snap8.2

I can see logs from foreman-proxy process:

[root@fdi ~]# journalctl -u foreman-proxy
-- Logs begin at Tue 2016-04-19 16:42:12 UTC, end at Wed 2016-04-20 06:37:03 UTC. --
Apr 19 16:42:23 fdi systemd[1]: Started Foreman Proxy.
Apr 19 16:44:24 fdi systemd[1]: Stopped Foreman Proxy.
Apr 19 16:44:26 fdi systemd[1]: Starting Foreman Proxy...
Apr 19 16:44:26 fdi generate-proxy-cert[1226]: Generating a 2048 bit RSA private key
Apr 19 16:44:26 fdi generate-proxy-cert[1226]: ...................+++
Apr 19 16:44:26 fdi generate-proxy-cert[1226]: ................................+++
Apr 19 16:44:26 fdi generate-proxy-cert[1226]: writing new private key to '/etc/foreman-proxy/key.pem'
Apr 19 16:44:26 fdi generate-proxy-cert[1226]: -----
Apr 19 16:44:26 fdi foreman-proxy[1275]: Finished initialization of module 'discovery_image'
Apr 19 16:44:26 fdi foreman-proxy[1275]: 'foreman_proxy' settings were initialized with default values: :enabled: true
Apr 19 16:44:26 fdi foreman-proxy[1275]: Finished initialization of module 'foreman_proxy'
Apr 19 16:44:26 fdi foreman-proxy[1275]: Finished initialization of module 'facts'
Apr 19 16:44:26 fdi foreman-proxy[1275]: Finished initialization of module 'bmc'
Apr 19 16:44:26 fdi systemd[1]: PID file /run/foreman-proxy/foreman-proxy.pid not readable (yet?) after start.
Apr 19 16:44:26 fdi systemd[1]: Started Foreman Proxy.
Apr 19 16:44:26 fdi foreman-proxy[1282]: WEBrick 1.3.1
Apr 19 16:44:26 fdi foreman-proxy[1282]: ruby 2.0.0 (2014-11-13) [x86_64-linux]
Apr 19 16:44:26 fdi foreman-proxy[1282]: TCPServer.new(0.0.0.0, 8443)
Apr 19 16:44:26 fdi foreman-proxy[1282]: TCPServer.new(::, 8443)
Apr 19 16:44:26 fdi foreman-proxy[1282]: TCPServer Error: Address already in use - bind(2)
Apr 19 16:44:26 fdi foreman-proxy[1282]: Certificate:
                                             Data:
                                                 Version: 3 (0x2)
                                                 Serial Number: 11086402602131776804 (0x99dad06da907e524)
                                             Signature Algorithm: sha256WithRSAEncryption
                                                 Issuer: CN=192.168.100.10
                                                 Validity
                                                     Not Before: Apr 19 16:44:26 2016 GMT
                                                     Not After : Jan 13 16:44:26 2019 GMT
                                                 Subject: CN=192.168.100.10
                                                 Subject Public Key Info:
                                                     Public Key Algorithm: rsaEncryption
                                                         Public-Key: (2048 bit)
lines 1-34


But I can see TCPServer error:  Address already in use - bind(2)
Comment 9 Sachin Ghai 2016-04-20 02:44:49 EDT
verifying this bz and will open a new bz for TCPServer error.
Comment 11 errata-xmlrpc 2016-07-27 05:24:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.