Bug 131389 - FC3 release notes -- nscd
FC3 release notes -- nscd
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Bailey
:
Depends On:
Blocks: fc-relnotes-blocker
  Show dependency treegraph
 
Reported: 2004-08-31 16:47 EDT by Ulrich Drepper
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 14:56:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2004-08-31 16:47:14 EDT
new functionality in glibc:

  the nscd (name service cache daemon) can now maintain a persistent
  cache which is not unconditionally removed when the program is
  restarted or the system reboots.  Entries are not removed from the
  cache until they are proved to be of no interest anymore.  All entries
  which expires time-to-live which are still interesting are
  automatically reloaded.  This helps in situations where the directory
  and name services become temporarily unavailable.
Comment 1 Ed Bailey 2004-09-02 14:56:17 EDT
Ulrich -- thanks for submitting this; how does this sound:

The nscd name service cache daemon now maintains a persistent cache
across restarts or system reboots.  Entries are not removed from the
cache until they are proven to be no longer of interest.  All entries
whose time-to-live expires but are otherwise interesting are
automatically reloaded, which helps in situations where the directory
and name services become temporarily unavailable.
Comment 2 Ulrich Drepper 2004-09-02 15:00:40 EDT
Fine with me.
Comment 3 Ed Bailey 2004-09-02 15:16:57 EDT
Super -- thanks for the quick feedback!  Added...
Comment 4 Ulrich Drepper 2004-10-18 17:30:48 EDT
Reading the text again, it might be a bid misleading.  The persistent
mode is optional and if the user updates an existing system the mode
might not be enabled by default.  How about
<<<
The nscd name service cache daemon may now maintain a persistent cache
across restarts or system reboots. Each database (user, group, and
host respectively) can be made selected to be persistent by setting
the appropriate line in /etc/nscd.conf to yes.  Entries are not
removed from the cache until they are proven to be no longer of
interest. All entries whose time-to-live expires but are otherwise
interesting are automatically reloaded, which helps in situations
where the directory and name services become temporarily unavailable.
>>>

And one more thanig: we have a second improvement in nscd which is
worth noting since it might need to be enabled.  Perhaps a paragraph like:

<<<
The nscd version in FC3 is also able to communicate faster with the
client programs.  This feature needs to be enable explicitly by
setting the "shared" entry for the appropriate database in
/etc/nscd.conf to "yes".
>>>

Comment 5 Ed Bailey 2004-10-19 14:56:00 EDT
Done.

Note You need to log in before you can comment on or make changes to this bug.