Bug 1313902 - Problems with resizing gedit window when launched from X11 forwarding [NEEDINFO]
Summary: Problems with resizing gedit window when launched from X11 forwarding
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gtk3
Version: 7.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Benjamin Otte
QA Contact: Desktop QE
URL:
Whiteboard:
: 1419212 (view as bug list)
Depends On:
Blocks: 1298243 1393395 1484996
TreeView+ depends on / blocked
 
Reported: 2016-03-02 15:12 UTC by Deepu K S
Modified: 2019-09-12 09:58 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-20 14:53:50 UTC
Target Upstream Version:
rstrode: needinfo? (dkochuka)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 741800 None None None 2016-06-24 18:27:54 UTC
Red Hat Knowledge Base (Solution) 2933881 None None None 2017-02-24 17:23:45 UTC

Description Deepu K S 2016-03-02 15:12:43 UTC
Description of problem:
On Linux (RHEL),
Resizing gedit (RHEL 7.2) window using mouse shows problems when launched using X11 forwarding on older RHEL 6/5.
Using --geometry options doesn't help. The WIDTHxHEIGHT doesn't work in --geometry options.
Resizing by dragging mouse doesn't work here.

This is happening after RHEL 7.2 GNOME update to 3.14.X . If downgraded to gedit 3.8 version, resizing with mouse is possible.

On Windows, gedit window cannot be resized using mouse when launched from other Xserver applications. eg :
MobaXterm
Oracle SGD

This issue is also seen for evince .

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 7.2
gedit-3.14.3-9.el7.x86_64

How reproducible:
Always.

Steps to Reproduce:
On Linux.
1. Connect to a RHEL 7.2 system from RHEL 6 using ssh X11 forward.
$ ssh -X RHEL7.2

2. Open gedit window.
$ gedit

3. Try resizing window, the resizing window pops up. Resizing by mouse drag doesn't work.

On Windows,
1. Open MobaXterm (http://mobaxterm.mobatek.net/) . Free version is available.
2. Launch gedit/evince from terminal.
3. Resizing Window is not possible.

Actual results:
Problems with resizing window in Linux.
Not able to resize window in Windows.

Expected results:
Should be able to resize window by mouse drag as in RHEL 7.0
The geometry options should work.

Additional info:
* Downgrading to gedit-3.8 works.
* On Windows, this issue is also seen in Oracle Secure Global Desktop(SGD).
* On Windows, resizing is possible with mouse on Xming Xserver. It looks like they are using an older version of Xserver.

Comment 1 charliehemlock 2016-06-23 22:23:42 UTC
I know this is Red Hat, but I'm also experiencing the same problem in CentOS 7.2.1511 using PuTTY + VcXsrv.

(VcXSrv is an Xming alternative I use for better clipboard support).

I've tried with VcXsrv 1.18.1.1 and 1.17.2.0 with same results.

I've tried accessing my CentOS 7 host from Windows 7 and 10 with same results.

However, when using Xming 6.9.0.31 rather than VcXsrv, I can resize gedit as in original post.

It only appears related to Gnome3/gtk3 applications. 
However these can be resized:

 gnome-terminal 3.14.3
 gnome-character-map


See here for more:
https://superuser.com/questions/1092777/cant-resize-some-gnome-3-applications-over-ssh-with-puttyvcxsrv

Comment 2 Ray Strode [halfline] 2016-06-24 18:27:55 UTC
This may be related to https://bugzilla.gnome.org/show_bug.cgi?id=741800

Comment 4 Ben Woodard 2017-02-16 23:56:19 UTC
*** Bug 1419212 has been marked as a duplicate of this bug. ***

Comment 15 Ray Strode [halfline] 2018-02-20 14:53:50 UTC
My understanding is that this issue was resolved in Red Hat Enterprise Linux 7.4:

   https://access.redhat.com/errata/RHBA-2017:2100

The relevant bug report that addressed this issue is bug 1386980.

I'm closing this bug report CURRENTRELEASE, but if for some reason, RHBA-2017:2100 was insufficient to address this issue, please comment or reopen.


Note You need to log in before you can comment on or make changes to this bug.