Bug 1313917 - [RFE] allow NFS hosted-engine system started on 3.4 to upgrade its filebase metadata and lockspace area to a VDSM volume as for fresh deployments
[RFE] allow NFS hosted-engine system started on 3.4 to upgrade its filebase m...
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
urgent Severity high (vote)
: ovirt-4.0.2
: 2.0.1.3
Assigned To: Simone Tiraboschi
Jiri Belka
integration
: FutureFeature
Depends On: 1364615
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 10:32 EST by Simone Tiraboschi
Modified: 2017-05-11 05:24 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This update supports the self-hosted engine upgrade path from Red Hat Enterprise Virtualization 3.4 to Red Hat Virtualization 4.0 by migrating filebase metadata and lockspace.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-12 10:25:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.z+
jbelka: testing_plan_complete-
mgoldboi: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 60369 master MERGED upgrade: migrate file based lockspace and metadata 2016-07-25 10:43 EDT
oVirt gerrit 61345 ovirt-hosted-engine-setup-2.0 MERGED upgrade: migrate file based lockspace and metadata 2016-07-26 07:41 EDT

  None (edit)
Description Simone Tiraboschi 2016-03-02 10:32:40 EST
Description of problem:

At 3.4 time, hosted-engine could be deployed only on NFS.
HA metadata and lockspace was just two files inside the storage domain and they were created outside VDSM.

The file based approach would not work with block devices.
So, since with 3.5 where we started supporting also iSCSI, we wrote new code to use VDSM volumes for metadata and lockpspace; ovirt-hosted-engine-ha supports both file and volume based metadata and lockspace since 3.5.

hosted-engine-setup since 3.5 is always creating two VDSM volumes also for NFS deployment.
There was no explicit upgrade path between 3.4 and 3.5 so who started with 3.4 on NFS and upgraded to 3.5 (and also to 3.6) is still using the filebased metadata also on 3.5 or on 3.6.
Filebased metadata and lockspace are still there in 3.6 but by far less tested since all the new user from 3.5 and from 3.6 are already with volumes.

4.0 is probably the right moment to unify them moving everybody to volumes. 

A critical point is that it would not be possibile to mix hosts that are using lockspace and metadata on files with hosts that are already pointing to a volume that is not in sync with the files at all so this upgrade will probably require to stop all the hosted-engine hosts (and obviously the engine VM) at the same time.

The only way to test the full upgrade path from 3.4 to 4.0 is:
3.4/el6 -> 3.5/el6 -> 3.5/el7 -> 3.6/el7 -> 4.0/el7
Comment 1 Sandro Bonazzola 2016-05-02 05:50:47 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 2 Doron Fediuck 2016-06-09 06:59:05 EDT
Removed dependencies as this is not blocking recent versions (after 3.4).
Comment 3 Jiri Belka 2016-08-08 13:17:05 EDT
ok, 3.4 -> 3.5 -> 3.6 -> 4.0 (ovirt-hosted-engine-setup-2.0.1.3-1.el7ev.noarch)

with some workarounds during the flow and there were some issues discovered:

BZ1365242, BZ1364557, BZ1364564, BZ1364568, BZ1364543, BZ1364571, BZ1364615

Note You need to log in before you can comment on or make changes to this bug.