Bug 1313957 - anaconda prefers i686 PAE kernel to x86_64 for x86_64 install if it's available
anaconda prefers i686 PAE kernel to x86_64 for x86_64 install if it's available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
24
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 1314027 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 11:53 EST by Adam Williamson
Modified: 2016-03-26 14:15 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-24.14-1 anaconda-24.13.1-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:15:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Fedora 24 live session (date: 2016-02-25) (49.50 KB, image/png)
2016-03-11 21:49 EST, Joachim Frieben
no flags Details

  None (edit)
Description Adam Williamson 2016-03-02 11:53:55 EST
Currently Pungi has a bug - https://bugzilla.redhat.com/show_bug.cgi?id=1313949 - causing the i686 kernels to be included in x86_64 repo. When you do an x86_64 install of current Rawhide or F24, you get the i686 PAE kernel instead of an x86_64 kernel, and the system fails to boot:

https://openqa.fedoraproject.org/tests/7017

obviously Pungi shouldn't be doing this, but ideally anaconda would prefer an x86_64 kernel to an i686 one for an x86_64 install, I think. It may be that this is made difficult by the need to prefer PAE kernels for 32-bit installs? But I figured I'd file it.

I'm nominating both this and the Pungi bug as Alpha blockers for now, that way we can decide which one is most important/simplest to fix and take it.
Comment 1 David Shea 2016-03-02 13:37:45 EST
*** Bug 1314027 has been marked as a duplicate of this bug. ***
Comment 2 Kamil Páral 2016-03-07 12:55:10 EST
Discussed at today's blocker review meeting [1]. Removing blocker nomination, because we accepted bug 1315434 as a blocker, which is a superset of this. Either this bug or bug 1313949 needs to get fixed.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-07/
Comment 3 Adam Williamson 2016-03-07 18:20:53 EST
https://github.com/rhinstaller/anaconda/pull/542 should fix this, I think. I'll test it.
Comment 4 Fedora Update System 2016-03-09 11:32:14 EST
anaconda-24.13.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d85d9ad927
Comment 5 Fedora Update System 2016-03-09 20:55:09 EST
anaconda-24.13.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d85d9ad927
Comment 6 Joachim Frieben 2016-03-10 22:07:21 EST
The latest live image still contains some i686 packages which also get installed after updating to anaconda-24.13.1-1.fc24 in the running live session:

- nss-softokn-freebl-3.23.0-0.1.fc24.i686
- glibc-2.23.1-5.fc24.i686
- xorg-x11-drv-geode-2.11.18-1.fc24.i686

Since anaconda-24.13.1-1.fc24 is in the updates testing repository, it is not possible to test the network install which would require an updated boot media. If I understand correctly though, these updates will only be merged into the main repository after the Fedora 24 Alpha freeze unless some test images are released.
Comment 7 Adam Williamson 2016-03-10 23:03:54 EST
please file a separate issue for that, that bug is not this bug.
Comment 8 Joachim Frieben 2016-03-11 20:54:36 EST
(In reply to Fedora Update System from comment #5)
Neither current Fedora 24 x86_64 live media nor current x86_64 boot images (both sporting the older anaconda-24.13-1.fc24) do include/install i686 kernel packages.
Comment 9 Adam Williamson 2016-03-11 21:03:26 EST
None of the images ever did include 32-bit kernels. The network installer (mostly) no longer installs them because we also fixed this from the other end; Pungi now properly excludes the 32-bit kernels from the x86_64 repos again.

The anaconda fix is still valid but less urgently needed. We have not done any builds with the anaconda from updates-testing because David Shea tells me it will likely crash the way the current Rawhide installer does, due to locale issues (it includes a change to C.UTF-8 as the default locale which turns out to have been a bad idea).
Comment 10 Joachim Frieben 2016-03-11 21:49 EST
Created attachment 1135476 [details]
Screenshot of Fedora 24 live session (date: 2016-02-25)

(In reply to Adam Williamson from comment #9)
Please convince yourself and look at the attached screenshot.
Comment 11 Fedora Update System 2016-03-26 14:14:48 EDT
anaconda-24.13.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.