This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1314027 - [anaconda] installs i686 PAE kernel on x86_64 system making it unbootable
[anaconda] installs i686 PAE kernel on x86_64 system making it unbootable
Status: CLOSED DUPLICATE of bug 1313957
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
24
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 13:37 EST by Joachim Frieben
Modified: 2016-03-02 13:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-02 13:37:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2016-03-02 13:37:10 EST
Description of problem:
Using the latest network install media for Fedora 24 Workstation x86_64, a number of i686 packages get installed, in particular the kernel package. Not surprisingly, the resulting system hangs upon boot. Installed i686 packages are

- glibc-2.23.1-5.fc24.i686
- kernel-PAE-4.5.0-0.rc6.git0.1.fc24.i686
- kernel-PAE-core-4.5.0-0.rc6.git0.1.fc24.i686
- kernel-PAE-modules-4.5.0-0.rc6.git0.1.fc24.i686
- nss-softokn-freebl-3.22.2-1.0.fc24.i686
- xorg-x11-drv-geode-2.11.18-1.fc24.i686 .

Version-Release number of selected component (if applicable):
anaconda-24.13-1.fc24

How reproducible:
Always

Steps to Reproduce:
1. Perform network install of Fedora 24 Workstation x86_64.
2. Reboot system.

Actual results:
The boot loader lists i686 boot kernels alone which do not boot on the x86_64 system.

Expected results:
Installed kernels are x86_64 in agreement with the rest of the system.

Additional info:
- Current live media of Fedora 24 Workstation x86_64 exhibit both x86_64 and i686+PAE kernels which is also unusual but at least enable the user to boot the system successfully.
Comment 1 David Shea 2016-03-02 13:37:45 EST

*** This bug has been marked as a duplicate of bug 1313957 ***

Note You need to log in before you can comment on or make changes to this bug.