Bug 1314033 - "Volume does not exist" errors appear when deleting a snapshot
"Volume does not exist" errors appear when deleting a snapshot
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.3.3
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.5
: 3.6.5
Assigned To: Ala Hino
Elad
:
Depends On: 1310615
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 13:50 EST by Natalie Gavrielov
Modified: 2016-04-21 10:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:41:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
tnisan: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)
engine.log, vdsm.log (2.10 MB, application/x-gzip)
2016-03-02 13:50 EST, Natalie Gavrielov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53864 master MERGED core: LiveMerge: Remove audit message when delete succeeds 2016-03-17 04:46 EDT

  None (edit)
Description Natalie Gavrielov 2016-03-02 13:50:14 EST
Created attachment 1132476 [details]
engine.log, vdsm.log

Description of problem:
When deleting a snapshot a few errors appear in engine.log saying volume doesn't exist.

Version-Release number of selected component (if applicable):
rhevm-3.6.3.3-0.1.el6.noarch
vdsm-4.17.23-0.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create VM (install OS and guest-agent).
2. Create snapshots (save memory).
3. Delete snapshots (one by one).

Actual results:
The following errors appear in engine.log:

2016-03-02 20:12:31,246 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.GetVolumeInfoVDSCommand] (pool-5-thread-3) [32cfe2a2] Failed in 'GetVolumeInfoVDS' method
2016-03-02 20:12:31,251 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-5-thread-3) [32cfe2a2] Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: VDSM aqua-vds5 command failed: Volume does not exist: (u'9eb820fb-da4d-44a2-bba8-96a931636dbb',)
2016-03-02 20:12:31,252 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.GetVolumeInfoVDSCommand] (pool-5-thread-3) [32cfe2a2] Command 'GetVolumeInfoVDSCommand(HostName = aqua-vds5, GetVolumeInfoVDSCommandParameters:{runAsync='true', hostId='da84a672-c913-4b1c-881a-b367a5646c47', storagePoolId='00000001-0001-0001-0001-000000000216', storageDomainId='855997f5-64fa-4f10-a08f-61e5ebcdf6f3', imageGroupId='8ad374fd-3d98-45e4-b7ff-b4c394adfd69', imageId='9eb820fb-da4d-44a2-bba8-96a931636dbb'})' execution failed: VDSGenericException: VDSErrorException: Failed to GetVolumeInfoVDS, error = Volume does not exist: (u'9eb820fb-da4d-44a2-bba8-96a931636dbb',), code = 201


Expected results:
For all operations to succeed. 

Additional info:
* Found while verifying bug #1313276.
* Storage domain type is NFS.
Comment 1 Allon Mureinik 2016-03-03 10:13:04 EST
Natalie, just to make sure - the snapshot deletion is also performed while the VM is running right?
Does it succeed and just produce a redudant ugly log message, or does it fail?
Comment 2 Natalie Gavrielov 2016-03-06 04:03:45 EST
(In reply to Allon Mureinik from comment #1)
> Natalie, just to make sure - the snapshot deletion is also performed while
> the VM is running right?
> Does it succeed and just produce a redundant ugly log message, or does it
> fail?

The VM was running (there is no memory to save if it's not), the snapshot succeeds.
It might seem like a redundant log message (but I usually assume that if there is an error - it indicates something went wrong).
Comment 3 Ala Hino 2016-03-06 04:17:20 EST
Root cause of this bug is same as of bug 1310615:
During DESTROY_IMAG_CHECK, we invoke getVolumeInfo in order to verify that the volume was deleted. We expect the getVolumeInfo command to fail but the framework running the command displays an error log  message an audit log message when command execution fails.
Comment 4 Ala Hino 2016-03-21 08:45:14 EDT
This bug resolved as a result of fixing bug 1310615.
To fix both bugs we introduced a new request parameter called engineExpectedErrors. This parameter is needed because there are use cases, like this one, where we send a request to vdsm and we expect to get an error, i.e. that's not a bug but actually this is the expected behavior.
So, here we shall see in the expectedEngineParameters 'VolumeDoesNotExist' value.
Comment 5 Allon Mureinik 2016-03-29 07:03:36 EDT
(In reply to Ala Hino from comment #4)
Setting requires-doctext to "-" - let's use bug 1310615 for documentation purposes.
Comment 6 Eyal Edri 2016-03-31 04:35:41 EDT
Bugs moved pre-mature to ON_QA since they didn't have target release.
Notice that only bugs with a set target release will move to ON_QA.
Comment 7 Elad 2016-03-31 10:39:50 EDT
Snapshot (that was taken with memory) live merge successful operation doesn't raise a "Volume does not exist" alert.

Used:
rhevm-3.6.5-0.1.el6.noarch
vdsm-4.17.25-0.el7ev.noarch

Note You need to log in before you can comment on or make changes to this bug.