Bug 1310615 - "Volume does not exist" alert is displayed when snapshot successfully deleted
"Volume does not exist" alert is displayed when snapshot successfully deleted
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.3
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.5
: 3.6.5
Assigned To: Ala Hino
Elad
:
: 1310614 (view as bug list)
Depends On:
Blocks: 1314033
  Show dependency treegraph
 
Reported: 2016-02-22 06:11 EST by Ala Hino
Modified: 2016-04-21 10:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: During live merge, after deleting the snapshot (volume) we verify that the snapshot was indeed deleted. This verification is done by running GetVolumeInfo that presents an alert if the volume doesn't exist Consequence: Misleading alert indicating volume doesn't exist Fix: We added a support to specify expected errors when executing commands and if an expected error is returned, we don't display an alert. In this use case, we specify that we expect Volume Not Found Error Result: The alert is not displayed anymore when verifying that snapshot was deleted
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:37:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
amureini: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53864 master MERGED core: LiveMerge: Remove audit message when delete succeeds 2016-03-17 04:46 EDT
oVirt gerrit 54958 ovirt-engine-3.6 MERGED core: Add support for suppressing audit log engine errors 2016-03-21 04:31 EDT
oVirt gerrit 54959 ovirt-engine-3.6 MERGED core: Remove redundant shouldLogToAudit method 2016-03-21 04:32 EDT
oVirt gerrit 54960 ovirt-engine-3.6 MERGED core: LiveMerge: Remove audit message when delete succeeds 2016-03-21 04:32 EDT
oVirt gerrit 54961 ovirt-engine-3.6 MERGED core: Remove index from curly braces 2016-03-21 04:32 EDT

  None (edit)
Description Ala Hino 2016-02-22 06:11:02 EST
Description of problem:
A misleading "Volume does not exist" is displayed when successfully deleting a snapshot.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Delete a snapshot while VM is running
2.
3.

Actual results:
Operation to complete w/o alerts (assuming delete succeeds)

Expected results:
A "Volume does not exist" alert is displayed

Additional info:
Comment 1 Ala Hino 2016-02-22 06:13:12 EST
*** Bug 1310614 has been marked as a duplicate of this bug. ***
Comment 2 Allon Mureinik 2016-03-29 07:02:43 EDT
This was a highly-visible (and annoying) customer-facing issue. Please add some doctext to explain what was going on here, and what was fixed.
Comment 3 Elad 2016-03-31 09:26:16 EDT
Snapshot live merge successful operation doesn't raise a "Volume does not exist" alert.

Used:
rhevm-3.6.5-0.1.el6.noarch
vdsm-4.17.25-0.el7ev.noarch

Note You need to log in before you can comment on or make changes to this bug.