This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1314069 - Backport the fix "Skip schema validation on GET /v2/images/%s" from upstream to python-glanceclient
Backport the fix "Skip schema validation on GET /v2/images/%s" from upstream ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-glanceclient (Show other bugs)
8.0 (Liberty)
All Linux
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: Flavio Percoco
Avi Avraham
: OtherQA
Depends On:
Blocks: 1194008 1314315
  Show dependency treegraph
 
Reported: 2016-03-02 14:47 EST by Zhen Qin
Modified: 2016-05-16 02:45 EDT (History)
11 users (show)

See Also:
Fixed In Version: python-glanceclient-1.1.1-1.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the Image service client could be configured to only allow uploading images in certain formats (for example, raw, ami, iso) to the Image service server. The client also allowed download of an image from the server only if it was in one of these formats. As a result of this restriction, users could no longer download images in other formats that had been previously uploaded. With this update, as the Image service server already validates image formats at the time they are imported, there is no need for the Image service client to verify image format when it is downloaded. As a result, the image format validation when an image is downloaded is now skipped, allowing the consumption of images in legitimate formats even if the client-side support for upload of images in those formats is no longer configured.
Story Points: ---
Clone Of:
: 1314315 (view as bug list)
Environment:
Last Closed: 2016-04-07 17:33:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 229560 None None None 2016-03-02 14:47 EST

  None (edit)
Description Zhen Qin 2016-03-02 14:47:15 EST
Description of problem:
The upstream fix (https://review.openstack.org/#/c/229560/) resolved the issue that schema validation on GET /v2/images/%s should be skipped on python-glanceclient. This patch is not in the latest release of OSP8 (a.k.a., OSP8-beta6) yet so we want RedHat backport this patch to OSP8. Thanks!

Version-Release number of selected component (if applicable):
python-glanceclient-1.1.0-1.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Zhen Qin 2016-03-11 12:09:30 EST
For your reference, here is the fix went into stable/liberty upstream:
https://review.openstack.org/#/c/288521/

Thanks.
Comment 3 Sergey Gotliv 2016-03-15 12:43:13 EDT
(In reply to Zhen Qin from comment #2)
> For your reference, here is the fix went into stable/liberty upstream:
> https://review.openstack.org/#/c/288521/
> 
> Thanks.

We are still waiting for community to create a new tag in the stable/liberty upstream.
Comment 4 Charles Crouch 2016-03-15 12:48:41 EDT
This was 'Depends on' 1194008, but I think it should be 'Blocks' 1194008
Comment 5 Charles Crouch 2016-03-15 12:50:57 EDT
This is an (In reply to Sergey Gotliv from comment #3)
> (In reply to Zhen Qin from comment #2)
> > For your reference, here is the fix went into stable/liberty upstream:
> > https://review.openstack.org/#/c/288521/
> > 
> > Thanks.
> 
> We are still waiting for community to create a new tag in the stable/liberty
> upstream.

This is an urgent bug fix for us, it is currently blocking some of our testing.
Can we please get this backported into the next RHELOSP8 beta before the new tag is created upstream.
Comment 6 Sergey Gotliv 2016-03-20 08:34:29 EDT
Fixed in python-glanceclient-1.1.1-1.el7ost

[1] https://brewweb.devel.redhat.com/buildinfo?buildID=486973
Comment 7 Charles Crouch 2016-03-21 11:45:26 EDT
Thanks so much Sergey. 
I noticed that you set the Target Milestone to ga. Is there any chance we could get this new package into the next RHELOSP8 beta release? Thank you again.
Comment 10 Sergey Gotliv 2016-04-02 10:02:08 EDT
(In reply to Charles Crouch from comment #7)
> Thanks so much Sergey. 
> I noticed that you set the Target Milestone to ga. Is there any chance we
> could get this new package into the next RHELOSP8 beta release? Thank you
> again.

Jon,

Is that build already available in our beta channel? Can we make it available if in case its not?
Comment 11 Avi Avraham 2016-04-03 09:40:32 EDT
verified. A test was performed that create an instance from image that it formant is no longer can be uploaded glance . A test plan was added to sanity tests
Comment 12 errata-xmlrpc 2016-04-07 17:33:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.