Bug 1314315 - Backport the fix "Skip schema validation on GET /v2/images/%s" from upstream to python-glanceclient
Backport the fix "Skip schema validation on GET /v2/images/%s" from upstream ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-glanceclient (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity high
: ---
: 7.0 (Kilo)
Assigned To: Flavio Percoco
nlevinki
: ZStream
Depends On: 1314069
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 06:59 EST by Flavio Percoco
Modified: 2016-10-05 15:15 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-glanceclient-0.17.3-3.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the Image service client could be configured to only allow uploading images in certain formats (for example, raw, ami, iso) to the Image service server. The client also allowed download of an image from the server only if it was in one of these formats. As a result of this restriction, users could not download images in other formats that had been previously uploaded. With this update, as the Image service server already validates image formats at the time they are imported, there is no need for the Image service client to verify image format when it is downloaded. As a result, the image format validation when an image is downloaded is now skipped, allowing the consumption of images in legitimate formats even if the client-side support for upload of images in those formats is no longer configured.
Story Points: ---
Clone Of: 1314069
Environment:
Last Closed: 2016-10-05 15:15:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 229560 None None None 2016-03-03 06:59 EST

  None (edit)
Comment 1 Mike McCune 2016-03-28 18:37:22 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 3 nlevinki 2016-10-05 06:36:33 EDT
Automation passed
https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/RHOS/view/RHOS7/job/qe-7_director-rhel-7.2-virthost-1cont_1comp_1ceph-ipv4-vxlan-ceph-ssl/3/
using this rpm
python-glanceclient-0.17.3-4.el7ost.noarch
Comment 5 errata-xmlrpc 2016-10-05 15:15:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2027.html

Note You need to log in before you can comment on or make changes to this bug.