Bug 1314095 - AttributeError: 'NoneType' object has no attribute 'mountpoints'
AttributeError: 'NoneType' object has no attribute 'mountpoints'
Status: CLOSED DUPLICATE of bug 1271657
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:12fe3fb298961d7636104f6d61f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 17:27 EST by iliketurtlesbro
Modified: 2016-03-03 05:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-03 05:08:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.30 MB, text/plain)
2016-03-02 17:27 EST, iliketurtlesbro
no flags Details
File: anaconda.log (97.16 KB, text/plain)
2016-03-02 17:27 EST, iliketurtlesbro
no flags Details
File: dnf.log (886 bytes, text/plain)
2016-03-02 17:27 EST, iliketurtlesbro
no flags Details
File: dnf.rpm.log (147 bytes, text/plain)
2016-03-02 17:27 EST, iliketurtlesbro
no flags Details
File: environ (459 bytes, text/plain)
2016-03-02 17:28 EST, iliketurtlesbro
no flags Details
File: lsblk_output (1.49 KB, text/plain)
2016-03-02 17:28 EST, iliketurtlesbro
no flags Details
File: lvm.log (407.41 KB, text/plain)
2016-03-02 17:28 EST, iliketurtlesbro
no flags Details
File: nmcli_dev_list (1.26 KB, text/plain)
2016-03-02 17:28 EST, iliketurtlesbro
no flags Details
File: os_info (451 bytes, text/plain)
2016-03-02 17:28 EST, iliketurtlesbro
no flags Details
File: storage.log (98.64 KB, text/plain)
2016-03-02 17:28 EST, iliketurtlesbro
no flags Details
File: syslog (588.83 KB, text/plain)
2016-03-02 17:28 EST, iliketurtlesbro
no flags Details
File: ifcfg.log (2.41 KB, text/plain)
2016-03-02 17:28 EST, iliketurtlesbro
no flags Details
File: packaging.log (694 bytes, text/plain)
2016-03-02 17:28 EST, iliketurtlesbro
no flags Details
File: program.log (58.85 KB, application/octet-stream)
2016-03-02 17:28 EST, iliketurtlesbro
no flags Details

  None (edit)
Description iliketurtlesbro 2016-03-02 17:27:52 EST
Description of problem:
Configuring hard disk settings for Fedora install: selected 'I would like to make additional space avalable.' and clicked 'Done' before encountering this bug. 

Version-Release number of selected component:
anaconda-24.13-1

The following was filed automatically by anaconda:
anaconda 24.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/packaging/dnfpayload.py", line 591, in spaceRequired
    for (key, val) in self.storage.mountpoints.items():
  File "/usr/lib64/python3.5/site-packages/pyanaconda/packaging/__init__.py", line 193, in requiredDeviceSize
    device_size = format_class.getRequiredSize(self.spaceRequired)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 88, in __init__
    required_dev_size = self.payload.requiredDeviceSize(FS.biggestOverheadFS())
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 961, in on_back_clicked
    dialog = ResizeDialog(self.data, self.storage, self.payload)
AttributeError: 'NoneType' object has no attribute 'mountpoints'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-E-dvd-x86_64-rawh rd.live.check quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.5.0-0.rc6.git0.1.fc25.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide
Comment 1 iliketurtlesbro 2016-03-02 17:27:57 EST
Created attachment 1132554 [details]
File: anaconda-tb
Comment 2 iliketurtlesbro 2016-03-02 17:27:58 EST
Created attachment 1132555 [details]
File: anaconda.log
Comment 3 iliketurtlesbro 2016-03-02 17:27:58 EST
Created attachment 1132556 [details]
File: dnf.log
Comment 4 iliketurtlesbro 2016-03-02 17:27:59 EST
Created attachment 1132557 [details]
File: dnf.rpm.log
Comment 5 iliketurtlesbro 2016-03-02 17:28:00 EST
Created attachment 1132558 [details]
File: environ
Comment 6 iliketurtlesbro 2016-03-02 17:28:01 EST
Created attachment 1132559 [details]
File: lsblk_output
Comment 7 iliketurtlesbro 2016-03-02 17:28:03 EST
Created attachment 1132560 [details]
File: lvm.log
Comment 8 iliketurtlesbro 2016-03-02 17:28:03 EST
Created attachment 1132561 [details]
File: nmcli_dev_list
Comment 9 iliketurtlesbro 2016-03-02 17:28:04 EST
Created attachment 1132562 [details]
File: os_info
Comment 10 iliketurtlesbro 2016-03-02 17:28:05 EST
Created attachment 1132563 [details]
File: storage.log
Comment 11 iliketurtlesbro 2016-03-02 17:28:07 EST
Created attachment 1132564 [details]
File: syslog
Comment 12 iliketurtlesbro 2016-03-02 17:28:08 EST
Created attachment 1132565 [details]
File: ifcfg.log
Comment 13 iliketurtlesbro 2016-03-02 17:28:08 EST
Created attachment 1132566 [details]
File: packaging.log
Comment 14 iliketurtlesbro 2016-03-02 17:28:10 EST
Created attachment 1132567 [details]
File: program.log
Comment 15 Jiri Konecny 2016-03-03 05:08:58 EST

*** This bug has been marked as a duplicate of bug 1271657 ***

Note You need to log in before you can comment on or make changes to this bug.