Bug 1314208 - GTK3 Popover menu cause screen flicking on Wayland with intel
GTK3 Popover menu cause screen flicking on Wayland with intel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Florian Müllner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2016-03-03 03:51 EST by Tommy He
Modified: 2016-03-15 00:16 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-15 00:16:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tommy He 2016-03-03 03:51:21 EST
Description of problem:

Screen flicking observed if invoking GTK3 Popover menu on Intel Graphics if Wayland is chosen as display server.

Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.99.917-19.20151206.fc23.x86_64
mutter-3.18.2-1.fc23.x86_64
gedit-3.18.3-1.fc23.x86_64
mesa-libwayland-egl-11.1.0-2.20151218.fc23.x86_64
kernel-4.4.3-300.fc23.x86_64
libdrm-2.4.66-1.fc23.x86_64

Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz


How reproducible:
100%

Steps to Reproduce:
1. Select "GNOME on Wayland" in GDM login
2. Launch gedit with GDK_BACKEND=wayland gedit
3. Invoke hamburger menu
4. Click anywhere else to dismiss the menu
5. Close gedit
6. Observe

Actual results:

Screen starts flicking from bottom part.

Expected results:

No screen flicking.

Additional info:

See my video recording of this issue on https://www.youtube.com/watch?v=1NGT5GJVhI0.

This issue doesn't happen if launched with GDK_BACKEND=x11 in a "GNOME on Wayland" session.

And this issue cannot be reproduced on a handful of devices using radeon driver.

Also, the screen flicking can go away by launching a full screen application like playing a video in full screen mode in VLC.
Comment 1 Tommy He 2016-03-03 03:54:41 EST
Note this issue does not only happens on Gedit but any other apps which utilizing GTK3 Popover menu.
Comment 2 Olivier Fourdan 2016-03-03 04:47:12 EST
Unlikely the X11 ddx being the problem in Wayland, either a gtk bug or a clutter/mutter issue (more likely because it occurs after gedit is closed)
Comment 3 Tommy He 2016-03-03 23:53:51 EST
(In reply to Olivier Fourdan from comment #2)
> Unlikely the X11 ddx being the problem in Wayland, either a gtk bug or a
> clutter/mutter issue (more likely because it occurs after gedit is closed)

Thanks for pointing it out.

Do you think I need to file a separate bug in GNOME Bugzilla? Or the one here is sufficient?
Comment 4 Christian Stadelmann 2016-03-04 03:50:04 EST
Are you sure this is an issue in Gtk/X11/Wayland? I'm just asking because the 4.4.x kernels before 4.4.4 which is due to be build probably today have a regression on intel GPUs that leads to flicker. See bug #1313318 for details.
Comment 5 Tommy He 2016-03-06 19:59:39 EST
Well, like I said, the problem does not happen if specifying GDK_BACKEND=x11.

Anyway, I'm pulling kernel 4.4.4 from updates-testing to give another try.
Comment 6 Tommy He 2016-03-15 00:16:23 EDT
This issue is no longer present after following two updates:

mutter-3.18.3-1.fc23.x86_64
kernel-4.4.4-301.fc23.x86_64

Whatever fixes in mutter or kernel issue, it's gone now.

Note You need to log in before you can comment on or make changes to this bug.