Bug 1314242 - WARNING: unable to delete selinux filesystems
WARNING: unable to delete selinux filesystems
Status: CLOSED DUPLICATE of bug 1312820
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 04:28 EST by Jan Synacek
Modified: 2016-03-04 05:33 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 05:33:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Synacek 2016-03-03 04:28:45 EST
Description of problem:
Whenever I build a package using mock, I get the following warning:

WARNING: unable to delete selinux filesystems (/tmp/mock-selinux-plugin.djsx0ecw): [Errno 1] Operation not permitted: '/tmp/mock-selinux-plugin.djsx0ecw'

It doesn't seem to affect any functionality.


Version-Release number of selected component (if applicable):
mock-1.2.15-1.fc23.noarch
selinux-policy-3.13.1-158.7.fc23.noarch


Steps to Reproduce:
1. $ mock -n --no-cleanup-after <srpm>


Actual results:
Warning.


Expected results:
No warning.


Additional info:
$ ls -Zla /tmp/mock-selinux-plugin.djsx0ecw
-r--r--r--. 1 root root unconfined_u:object_r:user_tmp_t:s0 336 Mar  3 10:21 /tmp/mock-selinux-plugin.djsx0ecw

$ cat /tmp/mock-selinux-plugin.djsx0ecw
nodev	sysfs
nodev	rootfs
nodev	ramfs
nodev	bdev
nodev	proc
nodev	cpuset
nodev	cgroup
nodev	tmpfs
nodev	devtmpfs
nodev	configfs
nodev	debugfs
nodev	tracefs
nodev	securityfs
nodev	sockfs
nodev	pipefs
nodev	devpts
	ext3
	ext2
	ext4
nodev	hugetlbfs
nodev	autofs
nodev	pstore
nodev	mqueue
nodev	binfmt_misc
	fuseblk
nodev	fuse
nodev	fusectl
Comment 1 Miroslav Suchý 2016-03-04 05:33:18 EST

*** This bug has been marked as a duplicate of bug 1312820 ***

Note You need to log in before you can comment on or make changes to this bug.