Bug 1314352 - Selecting multiple cores per socket not working against vmware provider (image cloning)
Selecting multiple cores per socket not working against vmware provider (imag...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources (Show other bugs)
6.1.7
All Linux
medium Severity medium (vote)
: GA
: --
Assigned To: Ivan Necas
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1315288
  Show dependency treegraph
 
Reported: 2016-03-03 07:40 EST by Dmitry Zhukovski
Modified: 2016-07-27 07:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: tfm-rubygem-fog-vsphere-0.6.3-1,foreman-1.11.0.30-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1315288 (view as bug list)
Environment:
Last Closed: 2016-07-27 07:03:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch against fog rebased to forg 1.24.1 (sat 6.1) (1.73 KB, patch)
2016-03-04 11:08 EST, Ivan Necas
no flags Details | Diff
cores per socket does get updated (102.97 KB, image/png)
2016-05-27 16:58 EDT, Kedar Bidarkar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14038 None None None 2016-04-26 13:06 EDT

  None (edit)
Description Dmitry Zhukovski 2016-03-03 07:40:34 EST
Description of problem:
Selecting multiple cores per socket not working against vmware provider (image cloning)

Version-Release number of selected component (if applicable):
sat6.1.7

How reproducible:
always

Steps to Reproduce:
1. Defaine new VNware ESX host from the image. 
2. Assign different to default=1 value to Cores per Socket.
3. Create a host

Actual results:
Deployed machine shows "Cores per socket" = 1

Expected results:
Deployed machine shows "Cores per socket" given value as well as machine resizes on several sockets in Vmware cluster


Additional info:
Comment 2 Ivan Necas 2016-03-03 07:54:09 EST
Created redmine issue http://projects.theforeman.org/issues/14038 from this bug
Comment 3 Bryan Kearney 2016-03-03 08:13:13 EST
Upstream bug assigned to inecas@redhat.com
Comment 8 Ivan Necas 2016-03-04 11:03:05 EST
After digging a bit deeper I've found the needed part on the fog part and opened a PR there: https://github.com/fog/fog-vsphere/pull/29
Comment 9 Ivan Necas 2016-03-04 11:08 EST
Created attachment 1133206 [details]
A patch against fog rebased to forg 1.24.1 (sat 6.1)

Additional patch to the foreman's on fog side to support setting the cores per socket setting.

To apply (when not patching the rpm):

```
cd /opt/rh/ruby193/root/usr/share/gems/gems/fog-1.24.1/
git init; git add .; git commit -m 'original' # optional just to track the changes
patch -p1 < numcorespersocket.patch
```
Comment 12 Bryan Kearney 2016-03-30 06:13:44 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14038 has been closed
-------------
Ivan Necas
Applied in changeset commit:17c277d5733cf4b814f3d5b357269f38bafcfa8f.
Comment 13 Kedar Bidarkar 2016-05-23 10:55:18 EDT
Tested with sat62-snap12.1 

Had selected the below options for the VM Tab :

Cpus: 2
Cores per socket: 2

After submitting the page found the below stuff,

Cpus: 2
Cores per socket: 1





~]# rpm -qav tfm-rubygem-fog-vsphere
tfm-rubygem-fog-vsphere-0.6.3-1.el7sat.noarch
Comment 16 Kedar Bidarkar 2016-05-27 16:58 EDT
Created attachment 1162543 [details]
cores per socket does get updated

VERIFIED with sat62-snap(GA)-13.1
Comment 17 Bryan Kearney 2016-07-27 07:03:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.