Bug 1314387 - [RFE][Tracker] - Provide streaming API for oVirt
[RFE][Tracker] - Provide streaming API for oVirt
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity high (vote)
: ovirt-4.1.0-alpha
: 4.1.0.2
Assigned To: Amit Aviram
Natalie Gavrielov
https://github.com/oVirt/ovirt-site/p...
: CodeChange, FutureFeature
Depends On:
Blocks: 1122970 1139877 1155676 1206691 1083269 RHEV_ISO_Uploader_UI 1428207
  Show dependency treegraph
 
Reported: 2016-03-03 08:38 EST by Yaniv Lavi
Modified: 2017-03-01 20:41 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This update adds the ability to download or upload Red Hat Virtualization images (for example, virtual machine images) using the Red Hat Virtualization API.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-01 09:50:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.1+
bmcclain: priority_rfe_tracking+
ratamir: testing_plan_complete+
ylavi: planning_ack+
amureini: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 66337 master MERGED core: Rename upload commands and variables to "transfer" 2016-11-17 12:59 EST
oVirt gerrit 66338 master MERGED core+restapi: Support image download 2016-11-17 13:00 EST

  None (edit)
Description Yaniv Lavi 2016-03-03 08:38:31 EST
Description of problem:
We have a lot of RFEs that require abilities to download\upload\do IO on data objects. This RFE is to track is to add the infrastructure to support these types of actions on storage.
Comment 1 Sandro Bonazzola 2016-05-02 06:04:17 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 3 Sandro Bonazzola 2016-12-12 08:56:58 EST
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.
Comment 4 Natalie Gavrielov 2017-01-03 05:39:58 EST
Verified,

I was able to upload / download images using:
python-ovirt-engine-sdk4-4.1.0-0.1.a0.20161226git77fce51.el7.centos.x86_64


with the following builds:

rhevm-4.1.0-0.3.beta2.el7.noarch
ovirt-imageio-proxy-0.5.0-0.el7ev.noarch
vdsm-4.19.1-1.el7ev.x86_64
ovirt-imageio-daemon-0.5.0-0.el7ev.noarch
vdsm-4.19.1-1.el7ev.x86_64
ovirt-imageio-daemon-0.5.0-0.el7ev.noarch
ovirt-imageio-common-0.5.0-0.el7ev.noarch

Note You need to log in before you can comment on or make changes to this bug.