Bug 1314404 - JBOSS BPM Process Model Error
JBOSS BPM Process Model Error
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Build (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vu Dinh
Wenjing Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 08:57 EST by jon_mckinley
Modified: 2016-04-04 07:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-04 07:50:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 488290 None None None 2016-03-03 08:57 EST

  None (edit)
Description jon_mckinley 2016-03-03 08:57:31 EST
Description of problem:
The web based process modeler in JBOSS BPM reports an error when you try and place a boundary event on a scripting task. It reports the following error:

"unable to parse xml : Exception class java.lang.IllegalArgumentException : Boundary events are supported only on StateBasedNode, found node: org.jbpm.workflow.core.node.ActionNode [_7FD9BA47-A0BE-4B4E-B8A8-CB9FF29ABB31]"

A quick search shows this is a known issues that has been fixed. Here is the link to that information: https://bugs.eclipse.org/bugs/show_bug.cgi?id=488290

However, I do not know how to apply this fix to the JBOSS Application in OpenShift since d not control the environment. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Place a scripting task in the process modeler
2.Attempt to drop a boundary event on it (it will not let you).

Alternatively
1. Place an unspecified task into the process modeler
2. Drop a boundary event on it (it will let you)
3. Try to compile the solution (you get the error message)

Actual results:
You can not develop a model that uses a boundary event on a scripting task
or
You can not compile a model that uses a boundary event on a scripting task


Expected results:
You should be able to place a boundary event on a scripting task and it should compile.


Additional info:
Comment 1 Kris Verlaenen 2016-03-05 17:13:27 EST
The core process engine does not support boundary events on scripting tasks (only for compensation).  The error that is returned is therefore correct.  The main reason is that script task are executed synchronously, using boundary events in this case is not useful in general.

Could you explain for what use case you would like to use a boundary event for on a script task?
Comment 2 Kris Verlaenen 2016-03-05 17:14:58 EST
Additional note: the bugzillas linked are regarding a fix for the Eclipse Bpmn2 Modeler, not the web-based Designer.  For Designer, the following might be relevant: https://bugzilla.redhat.com/show_bug.cgi?id=994408
Comment 3 jon_mckinley 2016-03-15 08:10:15 EDT
I was working an example from a BPMN book (jBPMN 6 Developer's Guide) that shows a error boundary event on an abstract task that represents a reason why the task can't be completed. This must be an error in the book and I just happened to find an IDE example of a similar... but different issue.  Or I am just not familiar enough with BPMN yet to understand what I am asking. I apologize for my error.

Note You need to log in before you can comment on or make changes to this bug.