Bug 131461 - rawhide-20040901 with Ethernet modules not loaded, initscripts reports "OK" for Bringing up interface eth*:
rawhide-20040901 with Ethernet modules not loaded, initscripts reports "OK" f...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-09-01 12:25 EDT by Daniel Reed
Modified: 2014-03-16 22:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8.08-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 15:41:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Reed 2004-09-01 12:25:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040704 Firefox/0.9.1

Description of problem:
After upgrading to rawhide-20040901, modprobe broke and my neither my
e1000 nor airo drivers were loaded. When I got to "Bringing up
interface eth0", however, the system reported OK immediately. Same for
eth1. Neither interface was brought up--in fact, neither one existed
in ifconfig -a (since their drivers were not loaded).

The initscripts should probably report a failure in this situation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade to rawhide-20040901
2. Reboot

Additional info:
Comment 1 Bill Nottingham 2004-09-01 12:47:38 EDT

*** This bug has been marked as a duplicate of 131441 ***
Comment 2 Daniel Reed 2004-09-01 12:54:39 EDT
This is a bug in the initscripts related to the interfaces being
reported as "OK"; it is not specifically related to 131452/131441.
Comment 3 Bill Nottingham 2004-09-01 13:01:01 EDT
If it's reproduced in the context of working modutils, please reopen.
Seriously, module-init-tools was broken enough that all sorts of
things can and would break.

*** This bug has been marked as a duplicate of 131441 ***
Comment 4 Daniel Reed 2004-09-01 22:01:49 EDT
Steps to Reproduce:
1. sed s/eth0/eth2/ < /etc/sysconfig/network-scripts/ifcfg-eth0 >
/etc/sysconfig/network-scripts/ifcfg-eth2
2. service network restart

The scripts will mark that it is trying to bring up eth2 and
immediately report "  OK  ". This is with the correct modutils package.
Comment 5 Bill Nottingham 2004-09-01 22:04:37 EDT
What eth* aliases do you have in /etc/modprobe.conf?
Comment 6 Daniel Reed 2004-09-01 22:58:23 EDT
My /etc/modprobe.conf is 0 bytes. My eth0 (airo) and eth1 (e1000) work
fine (airo and e1000 are both loaded without entries in modprobe.conf
or modprobe.conf.dist).

The problem is, I invented the concept of eth2 in terms of ifcfg-eth2,
the initscripts reported that they were bringing up the non-existent
eth2, then reported success at doing so! In some strange ways this
might make sense, but in view of the possibility that
actually-existing Ethernet devices might become unavailable do to
unrelated problems (such as the earlier modprobe problem), it seems
unwise to allow the initscripts to lie about the status of an
interface-upping.

ifup eth2 returns $?=0 in this situation. It should probably be that
this returns a failure code.
Comment 7 Bill Nottingham 2005-04-15 15:41:07 EDT
Fixed in 8.08-1.

Note You need to log in before you can comment on or make changes to this bug.