Bug 131441 - modprobe segfaulting - module-init-tools
Summary: modprobe segfaulting - module-init-tools
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 131452 131568 131677 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-01 14:48 UTC by Sammy
Modified: 2014-03-17 02:47 UTC (History)
4 users (show)

Fixed In Version: 3.1-0.pre5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 17:02:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2004-09-01 14:48:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en_US.UTF-8, en) (KHTML, like Gecko)

Description of problem:
After replacing modutils with module-init-tools I started getting segfaults
wtih modprobe. I first tried to remove an old kernel rpm using rpm -e
and got a segfault from modprobe message. Than tried logging into
KDE and everything hung at the "initializing system tools" level with
something cranking the disk (trying to restart).

Version-Release number of selected component (if applicable):
module-init-tools-3.1-0.pre5.1

How reproducible:
Always

Steps to Reproduce:
1.upgrade to module-init-tools
2.try to login to KDE
3.
    

Additional info:

Comment 1 Brian Millett 2004-09-01 15:30:40 UTC
Yep.  Trying to install a new kernel also shows the segfault.  Here is
a trace of my steps.  Funny output from running modprobe:

[bpm]$ sudo rpm --force  -ivh
/var/cache/yum/development/packages/kernel-2.6.8-1.538.i686.rpm
Preparing...               
########################################### [100%]
/var/tmp/rpm-tmp.24525: line 1: 12278 Segmentation fault     
/sbin/modprobe loop 2>/dev/null >/dev/null
   1:kernel                
########################################### [100%]
/
[bpm]$ sudo rpm -q --scripts kernel-2.6.8-1.538
preinstall scriptlet (using /bin/sh):
/sbin/modprobe loop 2> /dev/null > /dev/null  || :
exit 0
postinstall scriptlet (using /bin/sh):
[ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd
--depmod --install 2.6.8-1.538
if [ -x /usr/sbin/hardlink ] ; then
pushd /lib/modules/2.6.8-1.538/build > /dev/null ; {
        cd /lib/modules/2.6.8-1.538/build
        find . -type f | while read f; do hardlink -c
/lib/modules/*/build/$f $f ; done
}
popd
fi
preuninstall scriptlet (using /bin/sh):
/sbin/modprobe loop 2> /dev/null > /dev/null  || :
[ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --rminitrd
--rmmoddep --remove 2.6.8-1.538
[bpm]$ sudo /sbin/modprobe loop
# default modutils aliases
alias binfmt-204 binfmt_aout
Segmentation fault

Comment 2 Bill Nottingham 2004-09-01 16:47:46 UTC
*** Bug 131461 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2004-09-01 16:47:57 UTC
*** Bug 131452 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2004-09-01 17:01:08 UTC
*** Bug 131461 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2004-09-01 17:02:13 UTC
Fixed in 0.pre5.2.

Comment 6 Bill Nottingham 2004-09-02 19:49:15 UTC
*** Bug 131568 has been marked as a duplicate of this bug. ***

Comment 7 Zack Cerza 2004-09-03 03:35:20 UTC
*** Bug 131677 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.