Bug 1314611 - Thunderbird crash loop
Thunderbird crash loop
Status: CLOSED DUPLICATE of bug 1312868
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 23:40 EST by Cristián Rojas
Modified: 2016-03-04 16:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 16:27:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash_bt dump (3.62 KB, text/plain)
2016-03-04 09:23 EST, Cristián Rojas
no flags Details

  None (edit)
Description Cristián Rojas 2016-03-03 23:40:31 EST
Description of problem:

Can't open Thunderbird at all. It sends me right to Mozilla's Crash Reporter. When pressing "Restart Thunderbird" it shows again. 

Version-Release number of selected component (if applicable):

thunderbird-38.6.0-3.fc23.x86_64

How reproducible:

Steps to Reproduce:
1. Open Thunderbird. Crash Reporter shows up.
2. Press "Restart Thunderbird". Crash Reporter comes back.
3.

Actual results:

Crash Reporter loop

Expected results:

Mozilla Crash Reporter shows up.

Additional info:

I don't know how to disable Mozilla's Crash Reporter so that ABRT picks the error up.
Comment 1 Martin Stransky 2016-03-04 01:44:05 EST
Please try:

1) run thunderbird in safe mode ($thunderbird -safe-mode)
2) create a fresh new profile ($thunderbird -ProfileManager)
3) obtain a backtrace and attach it here (how-to is at http://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Application_crash)
Comment 2 Cristián Rojas 2016-03-04 09:23:13 EST
Martin:

Thank you very much for the steps. I can tell you the following:

1) Running in safe mode works. No Crash Report, no issues whatsoever.
2) On gdb run, i get the following:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffbee38700 (LWP 10674)]
findElementWithHash (pH=pH@entry=0x7fffc4117698, pKey=pKey@entry=0x7fffc12c95a2 "TRACKER", pHash=pHash@entry=0x7fffbee37764) at sqlite3.c:26813
26813	    if( sqlite3StrICmp(elem->pKey,pKey)==0 ){ 

I followed the steps of the guideline you indicated, and I'm attaching the crash_bt result.
Comment 3 Cristián Rojas 2016-03-04 09:23 EST
Created attachment 1133195 [details]
crash_bt dump
Comment 4 Martin Stransky 2016-03-04 09:32:10 EST
When it works in safe mode it means that some of your extension causes such crash. I recommend you to disable your extensions (in the safe mode) and enable them one by one and see which one causes the problem. Then report the broken extension to its author.
Comment 5 Cristián Rojas 2016-03-04 09:39:03 EST
OK. I reset the profile (rm -rf .thunderbird), uninstalled the tracker-thunderbird-plugin-1.6.1-1.fc23.x86_64 package and started Thunderbird in normal mode. It works now.
Comment 6 Cristián Rojas 2016-03-04 16:27:30 EST
Reassigned and marked as duplicate for #1312868

*** This bug has been marked as a duplicate of bug 1312868 ***

Note You need to log in before you can comment on or make changes to this bug.