Bug 1314646 - Incorrect error message on CLI on launching heal
Incorrect error message on CLI on launching heal
Status: CLOSED DUPLICATE of bug 1388509
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 02:16 EST by Anuradha
Modified: 2017-03-02 00:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-02 00:18:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anuradha 2016-03-04 02:16:04 EST
Description of problem:
When self-heal-daemon is off, and 'gluster volume heal <volname>' is run, the following error is displayed :

Launching heal operation to perform index self heal on volume test has been unsuccessful on bricks that are down. Please check if all brick processes are running.

This is incorrect.
Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. create a replicate volume
2. disable self-heal-daemon
3. try to launch heal using the above mentioned command

Actual results:
Errors out with the following message :
Launching heal operation to perform index self heal on volume test has been unsuccessful on bricks that are down. Please check if all brick processes are running.

Expected results:
Error message should be :
Self-heal-daemon is disabled. Heal will not be triggered on volume test

Additional info:
Comment 2 Ravishankar N 2017-03-02 00:18:26 EST

*** This bug has been marked as a duplicate of bug 1388509 ***

Note You need to log in before you can comment on or make changes to this bug.