Bug 1388509 - gluster volume heal info "healed" and "heal-failed" showing wrong information
Summary: gluster volume heal info "healed" and "heal-failed" showing wrong information
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
: 1314646 (view as bug list)
Depends On: 1331340 1333705 1500658 1500660 1500662
Blocks: 1361209
TreeView+ depends on / blocked
 
Reported: 2016-10-25 14:16 UTC by Mohit Agrawal
Modified: 2017-12-08 17:32 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.13.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1333705
Environment:
Last Closed: 2017-12-08 17:32:42 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2016-10-25 14:29:05 UTC
REVIEW: http://review.gluster.org/15724 (cli/afr: gluster volume heal info "healed" command output is not appropriate) posted (#1) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 2 Worker Ant 2016-11-10 08:42:50 UTC
REVIEW: http://review.gluster.org/15724 (cli/afr: gluster volume heal info "healed" command output is not appropriate) posted (#2) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 3 Worker Ant 2016-12-06 01:31:46 UTC
REVIEW: http://review.gluster.org/15724 (cli/afr: gluster volume heal info "healed" command output is not appropriate) posted (#3) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 4 Worker Ant 2016-12-07 05:26:06 UTC
REVIEW: http://review.gluster.org/15724 (cli/afr: gluster volume heal info "healed" command output is not appropriate) posted (#4) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 5 Worker Ant 2016-12-12 08:52:06 UTC
REVIEW: http://review.gluster.org/15724 (cli/afr: gluster volume heal info "healed" command output is not appropriate) posted (#5) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 6 Ravishankar N 2017-03-02 05:18:26 UTC
*** Bug 1314646 has been marked as a duplicate of this bug. ***

Comment 7 Worker Ant 2017-09-15 07:48:38 UTC
REVIEW: https://review.gluster.org/15724 (cli/afr: gluster volume heal info "healed" command output is not appropriate) posted (#6) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 8 Worker Ant 2017-09-19 04:40:27 UTC
REVIEW: https://review.gluster.org/15724 (cli/afr: gluster volume heal info "healed" command output is not appropriate) posted (#7) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 9 Worker Ant 2017-09-25 04:33:04 UTC
REVIEW: https://review.gluster.org/15724 (cli/afr: gluster volume heal info "healed" command output is not appropriate) posted (#8) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 10 Worker Ant 2017-10-03 05:48:36 UTC
REVIEW: https://review.gluster.org/15724 (cli/afr: gluster volume heal info "healed" command output is not appropriate) posted (#9) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 11 Worker Ant 2017-10-03 08:32:30 UTC
REVIEW: https://review.gluster.org/15724 (cli/afr: gluster volume heal info "healed" command output is not appropriate) posted (#10) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 12 Worker Ant 2017-10-04 04:33:20 UTC
COMMIT: https://review.gluster.org/15724 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit d1f15cdeb609a1b720a04a502f7a63b2d3922f41
Author: Mohit Agrawal <moagrawa@redhat.com>
Date:   Tue Oct 25 19:57:02 2016 +0530

    cli/afr: gluster volume heal info "healed" command output is not appropriate
    
    Problem: "gluster volume heal info [healed] [heal-failed]" command
              output on terminal is not appropriate in case of down any volume.
    
    Solution: To make message more appropriate change the condition
              in function "gd_syncop_mgmt_brick_op".
    
    Test : To verify the fix followed below procedure
           1) Create 2*3 distribute replicate volume
           2) set self-heal daemon off
           3) kill two bricks (3, 6)
           4) create some file on mount point
           5) bring brick 3,6 up
           6) kill other two brick (2 and 4)
           7) make self heal daemon on
           8) run "gluster v heal <vol-name>"
    
    Note: After apply the patch options (healed | heal-failed) will deprecate
          from command line.
    BUG: 1388509
    Change-Id: I229c320c9caeb2525c76b78b44a53a64b088545a
    Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>

Comment 13 Shyamsundar 2017-12-08 17:32:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.