Bug 1314813 - fedora-review does not clean up /tmp/mock-selinux-plugin paths
fedora-review does not clean up /tmp/mock-selinux-plugin paths
Status: CLOSED DUPLICATE of bug 1312820
Product: Fedora
Classification: Fedora
Component: fedora-review (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 10:08 EST by Randy Barlow
Modified: 2016-03-06 09:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-06 09:56:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2016-03-04 10:08:30 EST
I've noticed that fedora-review recently started to complain about not being able to remove some mock paths early on during the run:

$ fedora-review -rn ~/rpmbuild/SRPMS/pulp-docker-2.0.0-0.7.beta.1.fc25.src.rpm | grep WARNING
WARNING: unable to delete selinux filesystems (/tmp/mock-selinux-plugin.a2yxi_34): [Errno 1] Operation not permitted: '/tmp/mock-selinux-plugin.a2yxi_34'
WARNING: unable to delete selinux filesystems (/tmp/mock-selinux-plugin.ocxlc49v): [Errno 1] Operation not permitted: '/tmp/mock-selinux-plugin.ocxlc49v'
WARNING: unable to delete selinux filesystems (/tmp/mock-selinux-plugin.rciyn9ud): [Errno 1] Operation not permitted: '/tmp/mock-selinux-plugin.rciyn9ud'
WARNING: unable to delete selinux filesystems (/tmp/mock-selinux-plugin.nhwgipj1): [Errno 1] Operation not permitted: '/tmp/mock-selinux-plugin.nhwgipj1'

I can manually remove these paths, but it'd be nice if it cleaned them up for me.
Comment 1 gil cattaneo 2016-03-06 02:00:59 EST
https://bugzilla.redhat.com/show_bug.cgi?id=1312820
Comment 2 Alec Leamas 2016-03-06 09:56:26 EST
Indeed. Thanks for report and, not least, comment #2!

*** This bug has been marked as a duplicate of bug 1312820 ***

Note You need to log in before you can comment on or make changes to this bug.