Bug 1314933 - ipmitool kontronoem nextboot results in segmentation fault
ipmitool kontronoem nextboot results in segmentation fault
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipmitool (Show other bugs)
6.8
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Boris Ranto
Rachel Sibley
: Regression
Depends On:
Blocks: 1315737
  Show dependency treegraph
 
Reported: 2016-03-04 18:43 EST by Rachel Sibley
Modified: 2016-05-10 16:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: ipmitool-1.8.15-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1315737 (view as bug list)
Environment:
Last Closed: 2016-05-10 16:08:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachel Sibley 2016-03-04 18:43:03 EST
Description of problem:
Segmentation fault occurs if ipmitool kontronoem nextboot is executed without a supported device option.  If not supported, ipmitool should print a message stating it's not supported and device is not present. 

Version-Release number of selected component (if applicable):
~]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.8 Beta (Santiago)

~]# uname -r
2.6.32-621.el6.x86_64

~]# rpm -q ipmitool
ipmitool-1.8.15-1.el6.x86_64


How reproducible:
Always

Steps to Reproduce:
1. ipmitool kontronoem nextboot
2.
3.

Actual results:
Not enough parameters given.
nextboot <device>
Supported devices:
- BIOS
- FDD
- HDD
- CDROM
- network
Segmentation fault (core dumped)


Expected results:
No segmentation Fault, usage message stating it's not supported

Additional info:
Occurs on multiple systems running ipmitool-1.8.15-1.el6.x86_64 (RHEL 6.8 2.6.32-621.el6.x86_64).  Can not reproduce on ipmitool-1.8.13-8.el7_1.x86_64 (RHEL 7.2 3.10.0-326.el7.x86_64)
Comment 2 Boris Ranto 2016-03-08 07:27:12 EST
I think I can see where the problem lies. It was introduced by a code cleanup in lib/ipmi_kontronoem.c that went into 1.8.15 and it is actually a regression. I'll send a patch upstream. In the mean-time could you re-test with the following build to see if it fixed your problem:

https://brewweb.devel.redhat.com/taskinfo?taskID=10619443
Comment 4 Boris Ranto 2016-03-08 08:44:13 EST
The patch for this is already upstream, we need to back-port 12eeca602c104980cd36d89fa5b25ebd56b3c574 to fix this.
Comment 5 Rachel Sibley 2016-03-08 10:22:30 EST
Looks like this is resolved using your build, no longer seeing segmentation fault and usage message is displayed.

Before
================================
# rpm -q ipmitool
ipmitool-1.8.15-1.el6.x86_64

# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.8 Beta (Santiago)

#  ipmitool kontronoem nextboot
Not enough parameters given.
nextboot <device>
Supported devices:
- BIOS
- FDD
- HDD
- CDROM
- network
Segmentation fault (core dumped)

After
==============================
# yum install http://download.devel.redhat.com/brewroot/work/tasks/9447/10619447/ipmitool-1.8.15-2.el6.x86_64.rpm

# rpm -q ipmitool
ipmitool-1.8.15-2.el6.x86_64

# ipmitool kontronoem nextboot
Not enough parameters given.
nextboot <device>
Supported devices:
- BIOS
- FDD
- HDD
- CDROM
- network
Nextboot set failed
Comment 8 Rachel Sibley 2016-03-18 09:37:04 EDT
ALL TESTS PASSED

Verified as fixed in the ipmitool-1.8.15-2.el6.x86_64, no longer seeing a segmentation fault when running 'ipmitool kontronoem nextboot' without an option

~]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.8 Beta (Santiago)

~]# uname -r
2.6.32-627.el6.x86_64

~]# rpm -q ipmitool
ipmitool-1.8.15-2.el6.x86_64

~]#  ipmitool kontronoem nextboot
Not enough parameters given.
nextboot <device>
Supported devices:
- BIOS
- FDD
- HDD
- CDROM
- network
~]#
Comment 10 errata-xmlrpc 2016-05-10 16:08:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0771.html

Note You need to log in before you can comment on or make changes to this bug.