Bug 1315737 - [RHEL 7.3] ipmitool kontronoem nextboot results in segmentation fault
[RHEL 7.3] ipmitool kontronoem nextboot results in segmentation fault
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipmitool (Show other bugs)
7.3
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Josef Ridky
Rachel Sibley
: Regression
Depends On: 1314933
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 08:50 EST by Boris Ranto
Modified: 2016-11-03 19:30 EDT (History)
1 user (show)

See Also:
Fixed In Version: ipmitool-1.8.15-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1314933
Environment:
Last Closed: 2016-11-03 19:30:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Ranto 2016-03-08 08:50:10 EST
I've cloned this to fix it in RHEL 7.3 as well (it has got the same code-base).


+++ This bug was initially created as a clone of Bug #1314933 +++

Description of problem:
Segmentation fault occurs if ipmitool kontronoem nextboot is executed without a supported device option.  If not supported, ipmitool should print a message stating it's not supported and device is not present. 

Version-Release number of selected component (if applicable):
~]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.8 Beta (Santiago)

~]# uname -r
2.6.32-621.el6.x86_64

~]# rpm -q ipmitool
ipmitool-1.8.15-1.el6.x86_64


How reproducible:
Always

Steps to Reproduce:
1. ipmitool kontronoem nextboot
2.
3.

Actual results:
Not enough parameters given.
nextboot <device>
Supported devices:
- BIOS
- FDD
- HDD
- CDROM
- network
Segmentation fault (core dumped)


Expected results:
No segmentation Fault, usage message stating it's not supported

Additional info:
Occurs on multiple systems running ipmitool-1.8.15-1.el6.x86_64 (RHEL 6.8 2.6.32-621.el6.x86_64).  Can not reproduce on ipmitool-1.8.13-8.el7_1.x86_64 (RHEL 7.2 3.10.0-326.el7.x86_64)

--- Additional comment from Boris Ranto on 2016-03-08 07:27:12 EST ---

I think I can see where the problem lies. It was introduced by a code cleanup in lib/ipmi_kontronoem.c that went into 1.8.15 and it is actually a regression. I'll send a patch upstream. In the mean-time could you re-test with the following build to see if it fixed your problem:

https://brewweb.devel.redhat.com/taskinfo?taskID=10619443

--- Additional comment from Boris Ranto on 2016-03-08 08:44:13 EST ---

The patch for this is already upstream, we need to back-port 12eeca602c104980cd36d89fa5b25ebd56b3c574 to fix this.
Comment 4 Rachel Sibley 2016-05-25 09:07:18 EDT
ALL TESTS PASSED

Before
==========================
~]#  uname -r
3.10.0-408.el7.x86_64

~]# rpm -q ipmitool
ipmitool-1.8.15-5.el7.x86_64

~]#  ipmitool kontronoem nextboot
Not enough parameters given.
nextboot <device>
Supported devices:
- BIOS
- FDD
- HDD
- CDROM
- network
Segmentation fault
~]#


After
==========================
~]# uname -r
3.10.0-408.el7.x86_64

~]# rpm -q ipmitool
ipmitool-1.8.15-7.el7.x86_64

~]#  ipmitool kontronoem nextboot
Not enough parameters given.
nextboot <device>
Supported devices:
- BIOS
- FDD
- HDD
- CDROM
- network
~]#
Comment 6 Rachel Sibley 2016-10-20 08:10:21 EDT
Moving back to Verified State as it was incorrectly moved back to Assigned when switching the package owner.
Comment 8 errata-xmlrpc 2016-11-03 19:30:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2159.html

Note You need to log in before you can comment on or make changes to this bug.