Bug 1315090 - Numlock LED on keyboard switches off with non-US keyboard layouts
Numlock LED on keyboard switches off with non-US keyboard layouts
Status: CLOSED DUPLICATE of bug 1047151
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-06 09:20 EST by Seb L.
Modified: 2016-05-12 22:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 22:48:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seb L. 2016-03-06 09:20:26 EST
Description of problem:
When using IBus, the numlock LED switches off (only the LED, the function remains active which is very disturbing) once any modifier key such as [shift], [ctrl], etc. is pressed. Have to press numlock key twice to restore LED *and* function.
The LED switches off again after switching to another keyboard layout once a modifier key is pressed.

Version-Release number of selected component (if applicable):
ibus-1.5.11-1.fc23.x86_64

How reproducible:
Always

Steps to Reproduce:
- alternative 1:
1. Start Fedora 23
2. Ensure that the numlock function is on ( https://bugzilla.redhat.com/show_bug.cgi?id=1315087 )
3. Login in the DM (in my case: lightdm)
4. Wait for the WM (in my case: XFCE) to finish loading
5. Press [shift]

- alternative 2:
1. Ensure numlock LED *and* function are both on (double press numlock if needed)
2. Change IBus keyboard layout
3. Press [shift]

Actual results:
Numlock LED switches off, but the numlock function stays on.

Expected results:
Numlock LED *and* function should stay on.

Additional info:
Opening this as a new bug as per requested in https://bugzilla.redhat.com/show_bug.cgi?id=115909#c44 .

Seems related to:
  https://bugzilla.redhat.com/show_bug.cgi?id=1047151
  https://bbs.archlinux.org/viewtopic.php?id=162314
Comment 1 fujiwara 2016-03-29 00:01:13 EDT
I cannot reproduce your problem when I switch 'xkb:us::eng' and 'xkb:jp::jpn' engines.

Which engines do you switch?
You can check the current IBus engine name with 'ibus engine' command.

Are you reproduce your problem with a new user account instead of the current user account?
Comment 2 Benjamin Bellec 2016-05-05 07:21:57 EDT
This is a duplicate of #1047151, which has now a fix:
http://koji.fedoraproject.org/koji/buildinfo?buildID=760142

Please rate it at:
https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2f8b12e17
Comment 3 Seb L. 2016-05-12 16:33:07 EDT
Hi, sorry for the delay, I didn't have a workstation available for testing.
I just created a blank account on a Fedora 23/lightdm/XFCE 4 workstation, activated ibus and confirm that I can fully reproduce the bug.

Example of affected engines:
  xkb:fr::fra
  kkc
  xkb:us::eng

Any swap between any of those engine immediately triggered the bug.

However, upgrading from xorg-x11-server-1.18.3-1.fc23 to xorg-x11-server-1.18.3-2.fc23 *did* solve the issue.

=> bug could be closed, solved with http://koji.fedoraproject.org/koji/buildinfo?buildID=760142
Comment 4 fujiwara 2016-05-12 22:48:38 EDT
Closing this bug with the submitter's comment.

*** This bug has been marked as a duplicate of bug 1047151 ***

Note You need to log in before you can comment on or make changes to this bug.