Bug 1315186 - setting lower op-version should throw failure message
setting lower op-version should throw failure message
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Satish Mohan
:
Depends On: 1101702
Blocks: 1315562 1330545
  Show dependency treegraph
 
Reported: 2016-03-07 02:51 EST by Gaurav Kumar Garg
Modified: 2016-06-16 09:59 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1101702
: 1315562 1330545 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:59:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-07 03:16:26 EST
REVIEW: http://review.gluster.org/13622 (glusterd: avoid setting op-version lower then current cluster op-version) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Vijay Bellur 2016-03-07 06:00:26 EST
REVIEW: http://review.gluster.org/13622 (glusterd: avoid setting op-version lower than current cluster op-version) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 3 Vijay Bellur 2016-03-07 06:34:22 EST
REVIEW: http://review.gluster.org/13622 (glusterd: avoid setting op-version lower than current cluster op-version) posted (#3) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 4 Vijay Bellur 2016-03-07 23:55:03 EST
COMMIT: http://review.gluster.org/13622 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 2d87a981657ee23d00c20813deddeb320e0afa8f
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Mon Mar 7 13:37:31 2016 +0530

    glusterd: avoid setting op-version lower than current cluster op-version
    
    Currently glusterd allow setting a cluster op-version which is lower than
    current cluster op-version. Though command is successful but it does not
    set that lower op-version.
    
    With this fix it will return error message "Required op-version
    (requested op-version) should not be lower than current cluster
    op-version (current cluster op-version)"
    
    Change-Id: Ia5b61858ee22a5a26721ec12ab12ff48e1a40c82
    BUG: 1315186
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/13622
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 5 Atin Mukherjee 2016-04-26 03:25:15 EDT
The functionality in master is broken now due to commit 2eb8758, assigning it back.
Comment 6 Vijay Bellur 2016-04-26 03:25:48 EDT
REVIEW: http://review.gluster.org/14069 (glusterd: fix validation of lower op-version check in volume set) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 7 Vijay Bellur 2016-04-26 08:26:59 EDT
COMMIT: http://review.gluster.org/14069 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit f93761c547c39fad20f9aa96d4baf2641500b9a0
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Tue Apr 26 12:46:18 2016 +0530

    glusterd: fix validation of lower op-version check in volume set
    
    Commit 2d87a98 introduced a validation to fail lowering down the
    cluster.op-version. Commit 2eb8758 actually changed the variable value from
    cluster's op-version to volume's op-version which resulted the logic go for a
    toss.
    
    Change-Id: I70df32b75c3a3fe47dc840c4a655059e5b124bca
    BUG: 1315186
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/14069
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 10 Niels de Vos 2016-06-16 09:59:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.