Bug 1315562 - setting lower op-version should throw failure message
setting lower op-version should throw failure message
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Gaurav Kumar Garg
:
Depends On: 1315186 1330545
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 00:17 EST by Gaurav Kumar Garg
Modified: 2016-04-26 08:28 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1315186
Environment:
Last Closed: 2016-04-19 03:20:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-08 00:20:06 EST
REVIEW: http://review.gluster.org/13635 (glusterd: avoid setting op-version lower than current cluster op-version) posted (#1) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Vijay Bellur 2016-03-08 21:18:18 EST
COMMIT: http://review.gluster.org/13635 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit d1272ef0fdc9897fa388665e039b9f713109ef0c
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Mon Mar 7 13:37:31 2016 +0530

    glusterd: avoid setting op-version lower than current cluster op-version
    
    This patch is backport of: http://review.gluster.org/#/c/13622/
    
    Currently glusterd allow setting a cluster op-version which is lower than
    current cluster op-version. Though command is successful but it does not
    set that lower op-version.
    
    With this fix it will return error message "Required op-version
    (requested op-version) should not be lower than current cluster
    op-version (current cluster op-version)"
    
    Change-Id: Ia5b61858ee22a5a26721ec12ab12ff48e1a40c82
    BUG: 1315562
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    
      >> Change-Id: Ia5b61858ee22a5a26721ec12ab12ff48e1a40c82
      >> BUG: 1315186
      >> Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
      >> Reviewed-on: http://review.gluster.org/13622
      >> Smoke: Gluster Build System <jenkins@build.gluster.com>
      >> CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
      >> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
      >> Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    (cherry picked from commit 2d87a981657ee23d00c20813deddeb320e0afa8f)
    
    Change-Id: Ie75b2a0c43ab2c5a908f4d3800e1df62770d315b
    Reviewed-on: http://review.gluster.org/13635
    Tested-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Kaushal 2016-04-19 03:20:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.