Bug 1315275 - katello-agent install fails on rhel6.3 client
katello-agent install fails on rhel6.3 client
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.1.0
x86_64 Linux
unspecified Severity high (vote)
: Beta
: --
Assigned To: Justin Sherrill
Corey Welton
http://projects.theforeman.org/issues...
: ReleaseNotes, Triaged
Depends On: 1219157
Blocks: sat61-release-notes
  Show dependency treegraph
 
Reported: 2016-03-07 06:57 EST by Brad Buckingham
Modified: 2016-09-26 16:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1219157
Environment:
Last Closed: 2016-07-27 05:43:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1981503 None None None 2016-03-07 06:57 EST

  None (edit)
Comment 2 Justin Sherrill 2016-03-07 19:44:05 EST
Two issues here:

1.  openssl needs updating
2.  katello-agent isn't looking in the right place for its config


Problem 1 really can't be helped here as the technology that katello-agent uses requires a new openssl.  

Problem 2 can be fixed and will be the target of this BZ.
Comment 3 Justin Sherrill 2016-03-07 19:47:38 EST
Created redmine issue http://projects.theforeman.org/issues/14087 from this bug
Comment 4 Bryan Kearney 2016-03-07 20:12:46 EST
Upstream bug component is Content Management
Comment 5 Bryan Kearney 2016-03-09 16:13:31 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/14087 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello-agent|d4b7825af318ae024574d466830e896ebf78fb6d.
Comment 7 Tazim Kolhar 2016-04-03 09:34:46 EDT
VERIFIED:
# rpm -q foreman
foreman-1.11.0.9-1.el7sat.noarch



Steps:
1.register a client 6.3
2.yum repolist
3.set up a sat6 tools repo on client 6.3
# uname -a
Linux hp-bl460cgen8-01.rhts.eng.bos.redhat.com 2.6.32-279.el6.x86_64 #1 SMP Wed Jun 13 18:24:36 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux

4.yum install -y katello-agent
# rpm -qa katello-agent
katello-agent-2.2.6-1.el6.noarch
Comment 11 errata-xmlrpc 2016-07-27 05:43:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1503

Note You need to log in before you can comment on or make changes to this bug.