Bug 1315286 - Remove gutterball and associated functionality
Remove gutterball and associated functionality
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Unspecified
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: 6.2
Assigned To: Christine Fouant
Lukas Pramuk
http://projects.theforeman.org/issues...
: Triaged
: 1342103 1342284 (view as bug list)
Depends On: 1306038
Blocks: 1335807
  Show dependency treegraph
 
Reported: 2016-03-07 07:02 EST by Brad Buckingham
Modified: 2016-07-27 06:59 EDT (History)
11 users (show)

See Also:
Fixed In Version: katello-installer-base-3.0.0.38-1,katello-installer-base-3.0.0.39-1,katello-installer-base-3.0.0.40-1
Doc Type: Deprecated Functionality
Doc Text:
The gutterball engine has been removed from Red Hat Satellite 6.2. The data stored in gutterball was never used.
Story Points: ---
Clone Of: 1306038
Environment:
Last Closed: 2016-07-27 06:59:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14858 None None None 2016-04-27 15:07 EDT
Foreman Issue Tracker 15277 None None None 2016-06-02 22:19 EDT

  None (edit)
Comment 2 Christine Fouant 2016-04-27 14:19:18 EDT
Created redmine issue http://projects.theforeman.org/issues/14858 from this bug
Comment 3 Bryan Kearney 2016-04-27 16:14:01 EDT
Upstream bug component is Content Management
Comment 4 Bryan Kearney 2016-05-27 14:14:07 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14858 has been closed
Comment 7 Mike McCune 2016-06-01 17:04:51 EDT
This is still installed with SNAP14:

rpm -q satellite gutterball tfm-rubygem-hammer_cli_gutterball tfm-rubygem-foreman_gutterball 
satellite-6.2.0-14.1.el7sat.noarch
gutterball-1.0.15.0.2-1.el7.noarch
tfm-rubygem-hammer_cli_gutterball-1.0.1-5.el7sat.noarch
tfm-rubygem-foreman_gutterball-0.0.1-6.el7sat.noarch
Comment 8 Mike McCune 2016-06-01 17:09:03 EDT
Also upgrade from SNAP13 -> 14 fails with:

[ INFO 2016-06-01 16:54:55 main] Upgrade Step: remove_gutterball...
[DEBUG 2016-06-01 16:54:55 main] gutterball-1.0.15.0.2-1.el7.noarch

[ERROR 2016-06-01 16:54:55 main] error: Failed dependencies:
	tfm-rubygem(foreman_gutterball) is needed by (installed) satellite-6.2.0-14.1.el7sat.noarch
	tfm-rubygem(hammer_cli_gutterball) is needed by (installed) satellite-cli-6.2.0-14.1.el7sat.noarch

[ERROR 2016-06-01 16:54:55 main] rmdir: failed to remove ‘/var/lib/tomcat/webapps/gutterball’: Directory not empty

[ERROR 2016-06-01 16:54:55 main] Upgrade step remove_gutterball failed. Check logs for more information.
[DEBUG 2016-06-01 16:54:55 main] Exit with status code: 1 (signal was 1)
[ERROR 2016-06-01 16:54:55 main] Errors encountered during run:
[ERROR 2016-06-01 16:54:55 main] package elasticsearch is not installed

[ERROR 2016-06-01 16:54:55 main] error: Failed dependencies:
	tfm-rubygem(foreman_gutterball) is needed by (installed) satellite-6.2.0-14.1.el7sat.noarch
	tfm-rubygem(hammer_cli_gutterball) is needed by (installed) satellite-cli-6.2.0-14.1.el7sat.noarch

[ERROR 2016-06-01 16:54:55 main] rmdir: failed to remove ‘/var/lib/tomcat/webapps/gutterball’: Directory not empty

[ERROR 2016-06-01 16:54:55 main] Upgrade step remove_gutterball failed. Check logs for more information.
[DEBUG 2016-06-01 16:54:55 main] Cleaning /etc/foreman-installer/scenarios.d/d20160601-1900-7yyxo1
[DEBUG 2016-06-01 16:54:55 main] Cleaning /tmp/default_values.yaml
Comment 9 Brad Buckingham 2016-06-02 09:23:25 EDT
*** Bug 1342103 has been marked as a duplicate of this bug. ***
Comment 10 Lukas Pramuk 2016-06-02 10:04:39 EDT
hooks/post/30-upgrade.rb:46
  Kafo::Helpers.execute("rmdir /var/lib/tomcat/webapps/gutterball")

Please consider also RHEL6 !!!

# rmdir /var/lib/tomcat/webapps/gutterball
rmdir: failed to remove `/var/lib/tomcat/webapps/gutterball': No such file or ry

# rmdir /var/lib/tomcat6/webapps/gutterball
<success>
Comment 11 Lukas Pramuk 2016-06-02 10:12:02 EDT
We need to fix this even more - rhel6 tomcat dir
Thus switching back to ASSIGNED
Comment 12 Chris Duryee 2016-06-02 19:32:22 EDT
I created https://bugzilla.redhat.com/show_bug.cgi?id=1342284 for comments #8 and #10, I was not aware of this bz.
Comment 13 Mike McCune 2016-06-02 22:19:31 EDT
*** Bug 1342284 has been marked as a duplicate of this bug. ***
Comment 14 Lukas Pramuk 2016-06-04 04:23:01 EDT
VERIFIED.

@satellite-6.2.0-14.2.el6sat.noarch
katello-installer-base-3.0.0.40-1.el6sat.noarch

# satellite-installer --upgrade
...
Upgrade Step: restart_services...
Upgrade Step: db_seed...
Upgrade Step: import_package_groups (this may take a while) ...
Upgrade Step: import_rpms (this may take a while) ...
Upgrade Step: import_distributions (this may take a while) ...
Upgrade Step: import_puppet_modules (this may take a while) ...
Upgrade Step: import_subscriptions (this may take a while) ...
Upgrade Step: elasticsearch_message...
Elasticsearch has been removed as a dependency.  The database files can be removed manually with #rm -rf /var/lib/elasticsearch.  Some packages are no longer needed and can be removed:  #rpm -e ruby193-rubygem-tire tfm-rubygem-tire elasticsearch sigar-java sigar snappy-java lucene4-contrib lucene4
Upgrade Step: remove_docker_v1_content (this may take a while) ...
Upgrade Step: remove_gutterball...
Katello upgrade completed!


# rpm -qa *gutterball*
<empty>

# satellite-installer -h | grep gutterball
<empty>
Comment 15 Bryan Kearney 2016-07-27 06:59:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.