Bug 1315353 - pcsd should drop non-transparent reliance on SysV init environment when systemd in use
pcsd should drop non-transparent reliance on SysV init environment when syste...
Status: CLOSED DUPLICATE of bug 1252050
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Jelinek
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 09:24 EST by Jan Pokorný
Modified: 2016-03-07 10:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 10:30:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2016-03-07 09:24:22 EST
# systemctl status pcsd.service
> ● pcsd.service - PCS GUI and remote configuration interface
>    Loaded: loaded (/usr/lib/systemd/system/pcsd.service; enabled; vendor preset: disabled)
>    Active: active (running) since Mon 2016-03-07 15:02:27 CET; 9min ago
>  Main PID: 15743 (pcsd)
>    CGroup: /system.slice/pcsd.service
>            ├─15743 /bin/sh /usr/lib/pcsd/pcsd start
>            ├─15747 /bin/bash -c ulimit -S -c 0 >/dev/null 2>&1 ; /usr/bin/ruby -I/usr/lib/pcsd /usr/lib/pcsd/ssl.rb
>            └─15748 /usr/bin/ruby -I/usr/lib/pcsd /usr/lib/pcsd/ssl.rb
> [...]

From the administrator perspective, it's unclear why core dumps are
being disabled without using a native interface of systemctl.exec(5),
notably "LimitCORE=" option.  This makes unified management of the system
services harder (or "schizophrenic", if you want, cf. "LimitCORE=" in
service file vs. DAEMON_COREFILE_LIMIT variable in /etc/sysconfig/pcsd).

This is likely just a tip of the iceberg.
Comment 1 Tomas Jelinek 2016-03-07 10:30:28 EST

*** This bug has been marked as a duplicate of bug 1252050 ***

Note You need to log in before you can comment on or make changes to this bug.