Bug 1315415 - ipsec.conf manpage does not contain any mention about crl-strict option
ipsec.conf manpage does not contain any mention about crl-strict option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreswan (Show other bugs)
6.8
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Paul Wouters
Jaroslav Aster
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 11:38 EST by Jaroslav Aster
Modified: 2017-03-21 05:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1315412
Environment:
Last Closed: 2017-03-21 05:06:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Aster 2016-03-07 11:38:04 EST
The same issue on rhel-6 too.

libreswan-3.15-5.1.el6

+++ This bug was initially created as a clone of Bug #1315412 +++

Description of problem:

Based on the bug 1265410, crl-strict option is new variant of option strictcrlpolicy, which is marked as obsolete, but ipsec.conf manpage does not contain any mention about crl-strict option. There is only strictcrlpolicy option in ipsec.conf manpage.

Version-Release number of selected component (if applicable):

libreswan-3.15-5.el7_1

How reproducible:

100%

Steps to Reproduce:

# man ipsec.conf | col -b | grep 'crl-strict'
# man ipsec.conf | col -b | grep 'strictcrlpolicy'

Actual results:

There is no mention about crl-strict option in ipsec.conf manpage.

Expected results:

There is mention about crl-strict option in ipsec.conf manpage and this option is main.

Additional info:
Comment 1 Paul Wouters 2016-03-08 11:34:57 EST
this is already fixed upstream and will come in via the rebase in 7.[34] and it srhel-6.8 backport.
Comment 6 errata-xmlrpc 2017-03-21 05:06:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0575.html

Note You need to log in before you can comment on or make changes to this bug.