Bug 1315494 - C.UTF-8 doesn't actually work as a default locale
C.UTF-8 doesn't actually work as a default locale
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
https://github.com/rhinstaller/anacon...
AcceptedBlocker abrt_hash:b890a9b43d3...
: i18n
: 1323489 (view as bug list)
Depends On:
Blocks: F24BetaBlocker
  Show dependency treegraph
 
Reported: 2016-03-07 17:41 EST by Adam Williamson
Modified: 2016-04-06 10:06 EDT (History)
13 users (show)

See Also:
Fixed In Version: anaconda-24.13.2-1 anaconda-24.13.3-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 10:06:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (198.19 KB, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details
File: anaconda.log (41.11 KB, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details
File: dnf.log (716 bytes, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details
File: environ (455 bytes, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details
File: lsblk_output (1.31 KB, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details
File: nmcli_dev_list (1.20 KB, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details
File: os_info (451 bytes, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details
File: program.log (16.83 KB, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details
File: storage.log (26.42 KB, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details
File: syslog (63.05 KB, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details
File: ifcfg.log (2.24 KB, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details
File: packaging.log (188 bytes, text/plain)
2016-03-07 17:41 EST, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2016-03-07 17:41:37 EST
Description of problem:
This is a crash from openQA testing of Fedora-Server-dvd-x86_64-Rawhide-20160307.n.0.iso. It crashes immediately upon boot. Note the netinst does not crash in the same way.

Version-Release number of selected component:
anaconda-25.0-1

The following was filed automatically by anaconda:
anaconda 25.0-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/lib/lang_locale_handler.py", line 142, in _select_locale
    locale_itr = set_treeview_selection(self._localeView, locales[0], col=1)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 205, in initialize
    lang_itr, _locale_itr = self._select_locale(self.data.lang.lang)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/__init__.py", line 827, in run
    self._currentAction.initialize()
  File "/sbin/anaconda", line 1196, in <module>
    anaconda._intf.run()
IndexError: list index out of range

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-rawh quiet
dnf.rpm.log:    Mar 07 22:27:21 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.5.0-0.rc6.git3.1.fc25.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide
Comment 1 Adam Williamson 2016-03-07 17:41:41 EST
Created attachment 1133919 [details]
File: anaconda-tb
Comment 2 Adam Williamson 2016-03-07 17:41:42 EST
Created attachment 1133920 [details]
File: anaconda.log
Comment 3 Adam Williamson 2016-03-07 17:41:43 EST
Created attachment 1133921 [details]
File: dnf.log
Comment 4 Adam Williamson 2016-03-07 17:41:44 EST
Created attachment 1133922 [details]
File: environ
Comment 5 Adam Williamson 2016-03-07 17:41:45 EST
Created attachment 1133923 [details]
File: lsblk_output
Comment 6 Adam Williamson 2016-03-07 17:41:47 EST
Created attachment 1133924 [details]
File: nmcli_dev_list
Comment 7 Adam Williamson 2016-03-07 17:41:48 EST
Created attachment 1133925 [details]
File: os_info
Comment 8 Adam Williamson 2016-03-07 17:41:49 EST
Created attachment 1133926 [details]
File: program.log
Comment 9 Adam Williamson 2016-03-07 17:41:50 EST
Created attachment 1133927 [details]
File: storage.log
Comment 10 Adam Williamson 2016-03-07 17:41:52 EST
Created attachment 1133928 [details]
File: syslog
Comment 11 Adam Williamson 2016-03-07 17:41:53 EST
Created attachment 1133929 [details]
File: ifcfg.log
Comment 12 Adam Williamson 2016-03-07 17:41:54 EST
Created attachment 1133930 [details]
File: packaging.log
Comment 13 Adam Williamson 2016-03-07 17:46:03 EST
I'm guessing it's crashing on `locales[0]` here. Interestingly this doesn't seem to happen for me locally - note I'm in Canada, openQA is running in the US.
Comment 14 Adam Williamson 2016-03-07 17:47:11 EST
note from anaconda.log: "22:27:25,492 DEBUG anaconda: setting locale to: C.UTF-8"
Comment 15 David Shea 2016-03-08 09:30:44 EST
An easy way to reproduce is to turn off networking. That way geolocation doesn't fix the locale to one that langtable et al can do something with.
Comment 16 Adam Williamson 2016-03-08 10:56:32 EST
FWIW the "note the netinst does not crash the same way" from the OP was incorrect. in openQA, both DVD and netinst crash this way. For me running locally, neither do (though the locale is still set to C.UTF-8).
Comment 17 David Shea 2016-03-09 10:41:44 EST
Turns out that it's kind of hard to deal with locale data not actually telling us anything useful! This is going to become an issue in F24, since 5af1a3d9649c1f86a7dbc93a7844842f89c03e5d is on f24-branch as part of the fix for 1312607. However, after the change in lorax to install all glibc langpacks, and the change in glibc to ensure that at least one and most likely all langpacks get installed, anaconda can continue to use en_US.UTF-8 as the default. I'd like to revert that commit on F24 and deal with the more complicated task of handling crazy partially-available locale data on rawhide.
Comment 18 Fedora Blocker Bugs Application 2016-03-09 10:44:19 EST
Proposed as a Blocker for 24-alpha by Fedora user dshea using the blocker tracking app because:

 This is going to become an issue on alpha any time a user runs in an environment where geolocation data is not available. This causes a crash on the welcome screen, fitting the criterion of "The installer must run when launched normally from the release-blocking images. "

The solution is to revert a commit as outlined in the bug.
Comment 19 Adam Williamson 2016-03-09 11:01:28 EST
This crash hasn't actually been happening on F24, so far as I can tell.
Comment 20 David Shea 2016-03-09 11:02:55 EST
It will once there's a new build for F24, though.
Comment 21 Adam Williamson 2016-03-09 12:49:01 EST
Ah...well, sbueno did build anaconda-24.13.1-1.fc24 today. So should we hold off on doing any composes with that, and wait for a new build with the patch reverted?
Comment 22 Kamil Páral 2016-03-14 13:12:12 EDT
Discussed at today's blocker review meeting [1]. Voted as punt (delay decision) - this isn't a regular "need more info" punt, but the status is that the current stable anaconda does not have this bug so it is not technically a blocker, but if we need a new anaconda package for any other blocker fix, this becomes a blocker and must be fixed.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-14/
Comment 23 Jan Sedlák 2016-03-15 10:26:32 EDT
Still happening in Fedora-Rawhide-20160315.n.0. Doesn't happen in F24.
Comment 25 Adam Williamson 2016-03-23 14:27:33 EDT
Let's move this to the Beta blocker list, now Alpha was signed off with an earlier anaconda build that did not have the bug.
Comment 26 Raphael Groner 2016-03-29 02:09:47 EDT
Is there any doable workaround available? I tend to say this bug should better be proposed as freeze exception, except we do not know how to fix (yet). Can anaconda work with a native code page? Sorry if I did not read all the comments carefully.
Comment 27 Raphael Groner 2016-03-29 02:11:17 EDT
(In reply to David Shea from comment #24)
> https://github.com/rhinstaller/anaconda/pull/565

Okay, this means we could propose as freeze exception (see comment #26), when that upstream patch is not applied before beta freeze.
Comment 28 Stephen Gallagher 2016-03-29 08:39:32 EDT
There's basically zero chance that Beta would not have a newer Anaconda build, so I'm +1 beta blocker for this.
Comment 29 Kamil Páral 2016-03-29 12:54:50 EDT
Discussed at today's blocker review meeting [1]. Voted as AcceptedBlocker (Beta) - this clearly violates the criteria (installer fails to run at all) and it's unlikely we can make the Beta release with the same anaconda build we used for Alpha (which did not suffer from the bug)

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-29
Comment 30 Adam Williamson 2016-03-29 19:49:40 EDT
This is now a live issue for F24: anaconda-24.13.1-1.fc24 got pushed stable (autopush due to karma, probably granted by testers who tested by updating live images, which may bypass this bug) and anaconda now fails to run on all F24 images. See all the fails for today's F24 compose:

https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=24&build=Fedora-24-20160329.n.1&groupid=1

could we get a new F24 anaconda build with the fix for this ASAP? Thanks!
Comment 31 Fedora Update System 2016-03-31 15:43:19 EDT
anaconda-24.13.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ed73149773
Comment 32 Raphael Groner 2016-04-03 11:00:10 EDT
*** Bug 1323489 has been marked as a duplicate of this bug. ***
Comment 33 Raphael Groner 2016-04-03 11:16:27 EDT
Tried on a Thinkpad X220 bare metal, anaconda-24.13.2-1.fc24 works for me.
Comment 34 Fedora Update System 2016-04-04 17:25:39 EDT
anaconda-24.13.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd26edfec7
Comment 35 Fedora Update System 2016-04-05 15:22:14 EDT
anaconda-24.13.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd26edfec7
Comment 36 Fedora Update System 2016-04-06 10:06:14 EDT
anaconda-24.13.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.