Bug 1323489 - IndexError: list index out of range
Summary: IndexError: list index out of range
Status: CLOSED DUPLICATE of bug 1315494
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 24
Hardware: x86_64 Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b890a9b43d3b8f25b4885fb90b5...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-03 14:56 UTC by Raphael Groner
Modified: 2016-04-03 15:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-03 15:00:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (438.65 KB, text/plain)
2016-04-03 14:56 UTC, Raphael Groner
no flags Details
File: anaconda.log (53.72 KB, text/plain)
2016-04-03 14:56 UTC, Raphael Groner
no flags Details
File: environ (570 bytes, text/plain)
2016-04-03 14:56 UTC, Raphael Groner
no flags Details
File: journalctl (274.94 KB, text/plain)
2016-04-03 14:56 UTC, Raphael Groner
no flags Details
File: lsblk_output (2.08 KB, text/plain)
2016-04-03 14:56 UTC, Raphael Groner
no flags Details
File: nmcli_dev_list (1.21 KB, text/plain)
2016-04-03 14:56 UTC, Raphael Groner
no flags Details
File: os_info (449 bytes, text/plain)
2016-04-03 14:56 UTC, Raphael Groner
no flags Details
File: program.log (45.18 KB, text/plain)
2016-04-03 14:56 UTC, Raphael Groner
no flags Details
File: storage.log (117.09 KB, text/plain)
2016-04-03 14:56 UTC, Raphael Groner
no flags Details
File: ifcfg.log (2.27 KB, text/plain)
2016-04-03 14:56 UTC, Raphael Groner
no flags Details

Description Raphael Groner 2016-04-03 14:56:16 UTC
Description of problem:
boot into f24 kde livemedia for 20160403, click on install

Version-Release number of selected component:
anaconda-core-24.13.1-1.fc24.x86_64

The following was filed automatically by anaconda:
anaconda 24.13.1-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/lib/lang_locale_handler.py", line 142, in _select_locale
    locale_itr = set_treeview_selection(self._localeView, locales[0], col=1)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 205, in initialize
    lang_itr, _locale_itr = self._select_locale(self.data.lang.lang)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/__init__.py", line 827, in run
    self._currentAction.initialize()
  File "/sbin/anaconda", line 1196, in <module>
    anaconda._intf.run()
IndexError: list index out of range

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img root=live:CDLABEL=Fedora-KDE-Live-24-20160403-n-0 rd.live.image rd.live.check quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.5.0-302.fc24.x86_64
other involved packages: anaconda-gui-24.13.1-1.fc24.x86_64
product:        Fedora
release:        Fedora release 24 (Twenty Four)
type:           anaconda
version:        24

Potential duplicate: bug 1315494

Comment 1 Raphael Groner 2016-04-03 14:56:22 UTC
Created attachment 1143011 [details]
File: anaconda-tb

Comment 2 Raphael Groner 2016-04-03 14:56:24 UTC
Created attachment 1143012 [details]
File: anaconda.log

Comment 3 Raphael Groner 2016-04-03 14:56:25 UTC
Created attachment 1143013 [details]
File: environ

Comment 4 Raphael Groner 2016-04-03 14:56:28 UTC
Created attachment 1143014 [details]
File: journalctl

Comment 5 Raphael Groner 2016-04-03 14:56:30 UTC
Created attachment 1143015 [details]
File: lsblk_output

Comment 6 Raphael Groner 2016-04-03 14:56:31 UTC
Created attachment 1143016 [details]
File: nmcli_dev_list

Comment 7 Raphael Groner 2016-04-03 14:56:33 UTC
Created attachment 1143017 [details]
File: os_info

Comment 8 Raphael Groner 2016-04-03 14:56:35 UTC
Created attachment 1143018 [details]
File: program.log

Comment 9 Raphael Groner 2016-04-03 14:56:37 UTC
Created attachment 1143019 [details]
File: storage.log

Comment 10 Raphael Groner 2016-04-03 14:56:38 UTC
Created attachment 1143020 [details]
File: ifcfg.log

Comment 11 Raphael Groner 2016-04-03 15:00:10 UTC

*** This bug has been marked as a duplicate of bug 1315494 ***

Comment 12 Raphael Groner 2016-04-03 15:01:37 UTC
Tried on a Thinkpad X220 bare metal.

Comment 13 Raphael Groner 2016-04-03 15:15:35 UTC
anaconda-24.13.2-1.fc24 works for me.


Note You need to log in before you can comment on or make changes to this bug.