Bug 1315582 - Geo-replication CPU usage is 100%
Geo-replication CPU usage is 100%
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Aravinda VK
:
Depends On:
Blocks: glusterfs-3.7.9 1315601
  Show dependency treegraph
 
Reported: 2016-03-08 01:59 EST by Aravinda VK
Modified: 2016-04-19 03:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1315601 (view as bug list)
Environment:
Last Closed: 2016-03-22 04:14:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2016-03-08 01:59:59 EST
Description of problem:
Geo-replication CPU usage is 100% without any I/O.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
Start Geo-replication and watch CPU usage.


Actual results:
CPU usage is 100%

Expected results:
CPU usage should not be 100%
Comment 1 Vijay Bellur 2016-03-08 06:17:10 EST
REVIEW: http://review.gluster.org/13645 (geo-rep: Fix CPU utilization 100% with Popen) posted (#1) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 2 Vijay Bellur 2016-03-08 11:32:47 EST
COMMIT: http://review.gluster.org/13645 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit c249931f2ca37d56391e671b37479555fec92686
Author: Aravinda VK <avishwan@redhat.com>
Date:   Tue Mar 8 13:41:58 2016 +0530

    geo-rep: Fix CPU utilization 100% with Popen
    
    Errorstore is maintained by Geo-rep to collect errors from
    the child processes opened using Popen. If Popen.communicate
    is used then it closes stderr. When stderr is not available
    errorstore.tailer() will enter into infinite loop without gap.
    
    With this patch, sleep time added when stderr of Child process
    is already closed.
    
    Change-Id: Ic36aabd6de35b259467d0bab7952468432867a94
    BUG: 1315582
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/13637
    Reviewed-on: http://review.gluster.org/13645
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Kaushal 2016-04-19 03:21:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.