Bug 1315610 - Routing errors due to missing .css files on navigating sync status page
Routing errors due to missing .css files on navigating sync status page
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: 6.2
Assigned To: Walden Raines
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
: 1312724 1335147 1347166 (view as bug list)
Depends On: 1318041
Blocks: 1122832
  Show dependency treegraph
 
Reported: 2016-03-08 03:46 EST by Sachin Ghai
Modified: 2016-07-27 07:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.51-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:02:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
routing errors on navigating sync status page (75.16 KB, image/png)
2016-03-08 03:46 EST, Sachin Ghai
no flags Details
"NetworkError: 404 Not Found - /assets/katello/input-bg.png (50.06 KB, image/png)
2016-05-18 05:46 EDT, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14163 None None None 2016-04-22 10:54 EDT

  None (edit)
Description Sachin Ghai 2016-03-08 03:46:58 EST
Created attachment 1134069 [details]
routing errors on navigating sync status page

Description of problem:
On navigating 'sync status' page, couple of routing error being raised under production.log and firebug raises 404 for missing .css files.

2016-03-08 03:41:03 [app] [I] Started GET "/assets/katello/jquery-ui-1.8.11.custom.css" for 10.65.193.200 at 2016-03-08 03:41:03 -0500
2016-03-08 03:41:03 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/katello/jquery-ui-1.8.11.custom.css"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'


2016-03-08 03:41:04 [app] [I] Started GET "/assets/katello/jquery.loadmask.css" for 10.65.193.200 at 2016-03-08 03:41:04 -0500
2016-03-08 03:41:04 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/katello/jquery.loadmask.css"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'


2016-03-08 03:41:04 [app] [I] Started GET "/assets/katello/jquery.treeTable.css" for 10.65.193.200 at 2016-03-08 03:41:04 -0500
2016-03-08 03:41:04 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/katello/jquery.treeTable.css"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'

2016-03-08 03:41:04 [app] [I] Started GET "/assets/katello/jquery.jscrollpane.css" for 10.65.193.200 at 2016-03-08 03:41:04 -0500
2016-03-08 03:41:04 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/katello/jquery.jscrollpane.css"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
 |   railties (4.1.5) lib/rails/rack/logger.rb:38:in `call_app'



2016-03-08 03:41:04 [app] [I] Started GET "/assets/katello/ui.spinner.css" for 10.65.193.200 at 2016-03-08 03:41:04 -0500
2016-03-08 03:41:04 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/katello/ui.spinner.css"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'

2016-03-08 03:41:10 [app] [I] Started GET "/assets/katello/input-bg.png" for 10.65.193.200 at 2016-03-08 03:41:10 -0500
2016-03-08 03:41:10 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/katello/input-bg.png"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
 |   railties (4.1.5) lib/rails/rack/logger.rb:38:in `call_app'
 |   railties (4.1.5) lib/rails/rack/logger.rb:22:in `call'
 



Version-Release number of selected component (if applicable):
sat6.2 snap2

How reproducible:
always

Steps to Reproduce:
1. navigate sync status page
2.
3.

Actual results:
ActionController::RoutingError (No route matches [GET] "/assets/katello/ui.spinner.css"):

RoutingError (No route matches [GET] "/assets/katello/input-bg.png"):

RoutingError (No route matches [GET] "/assets/katello/jquery.jscrollpane.css"):


Expected results:
UI shouldn't raise routing errors on navigating sync status page

Additional info:
Comment 2 Walden Raines 2016-03-11 11:49:17 EST
Note that this is the case on all old katello pages (sync status and red hat repositories).
Comment 3 Walden Raines 2016-03-11 12:45:29 EST
Created redmine issue http://projects.theforeman.org/issues/14163 from this bug
Comment 4 Bryan Kearney 2016-03-11 14:01:45 EST
Upstream bug component is WebUI
Comment 5 Walden Raines 2016-03-11 15:06:43 EST
*** Bug 1312724 has been marked as a duplicate of this bug. ***
Comment 7 Bryan Kearney 2016-03-21 18:01:46 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14163 has been closed
-------------
Eric Helms
Applied in changeset commit:katello|e9b932c6e3ebe158301827f0e6e45f23303a24a9.
Comment 8 Sachin Ghai 2016-05-18 05:44:21 EDT
Still reproducible with Sat6.2 GA snap11.0

I can still see one routing error on navigating sync status page:

2016-05-18 05:42:26 [app] [I] Started GET "/assets/katello/sync_management/index-89eb9609d01af85cc1abb74bed4ccbe9ae86c789c1d165e2d4a06cb4a076d307.js" for 10.65.223.218 at 2016-05-18 05:42:26 -0400
2016-05-18 05:42:30 [app] [I] Started GET "/assets/katello/icons/expander-collapsed-842ef51fdbcfbc0614dafd6d2f93ec1e917041213bbacaae5169b9d7e0d91140.png" for 10.65.223.218 at 2016-05-18 05:42:30 -0400
2016-05-18 05:42:30 [app] [I] Started GET "/assets/katello/input-bg.png" for 10.65.223.218 at 2016-05-18 05:42:30 -0400
2016-05-18 05:42:30 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/katello/input-bg.png"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
 |   railties (4.1.5) lib/rails/rack/logger.rb:38:in `call_app'
 |   railties (4.1.5) lib/rails/rack/logger.rb:22:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/request_id.rb:21:in `call'
 |   rack (1.5.2) lib/rack/methodoverride.rb:21:in `call'
 |   rack (1.5.2) lib/rack/runtime.rb:17:in `call'
 |   activesupport (4.1.5) lib/active_support/cache/strategy/local_cache_middleware.rb:26:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/static.rb:64:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/static.rb:64:in `call'
 |   rack (1.5.2) lib/rack/sendfile.rb:112:in `call'
 |   railties (4.1.5) lib/rails/engine.rb:514:in `call'
 |   railties (4.1.5) lib/rails/application.rb:144:in `call'
 |   railties (4.1.5) lib/rails/railtie.rb:194:in `public_send'
 |   railties (4.1.5) lib/rails/railtie.rb:194:in `method_missing'
 |   rack (1.5.2) lib/rack/builder.rb:138:in `call'
 |   rack (1.5.2) lib/rack/urlmap.rb:65:in `block in call'
 |   rack (1.5.2) lib/rack/urlmap.rb:50:in `each'
 |   rack (1.5.2) lib/rack/urlmap.rb:50:in `call'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'
 |   logging (1.8.2) lib/logging/diagnostic_context.rb:323:in `call'
 |   logging (1.8.2) lib/logging/diagnostic_context.rb:323:in `block in create_with_logging_context'
Comment 9 Sachin Ghai 2016-05-18 05:46 EDT
Created attachment 1158695 [details]
"NetworkError: 404 Not Found - /assets/katello/input-bg.png
Comment 10 Mike McCune 2016-05-26 17:00:45 EDT
*** Bug 1335147 has been marked as a duplicate of this bug. ***
Comment 11 Bryan Kearney 2016-06-15 18:12:30 EDT
Upstream bug assigned to ehelms@redhat.com
Comment 14 Walden Raines 2016-06-16 16:04:41 EDT
PR: https://github.com/Katello/katello/pull/6131
Comment 16 Bryan Kearney 2016-06-17 11:45:12 EDT
*** Bug 1347166 has been marked as a duplicate of this bug. ***
Comment 17 Walden Raines 2016-06-17 13:28:24 EDT
Revision f8fbc921
Added by Walden Raines about 21 hours ago

Fixes #14163: namespace image urls and use image-url helper.

We were getting 404s for images in production mode because we were not
using the correct paths to images and also not using the image-url
helper. This commit fixes these issues.

http://projects.theforeman.org/issues/14163

Revision 757dcedb
Added by Walden Raines about 4 hours ago

Merge pull request #6131 from waldenraines/14163

Fixes #14163: namespace image urls and use image-url helper.
Comment 18 Lukas Zapletal 2016-06-20 07:44:07 EDT
One observation - when all repositories are synced, the problem disappears and the page is operational again.
Comment 19 Sachin Ghai 2016-06-27 05:21:59 EDT
Verified with sat62 GA snap17, the reported issue related to routing error due to missing .css files is not longer reproducible with snap17.

For the issue reported in comment18 another bz is filed here: https://bugzilla.redhat.com/show_bug.cgi?id=1347095

So moving this to verified.
Comment 20 Bryan Kearney 2016-07-27 07:02:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.