Bug 1347095 - 6.2 Beta2 - Sync Status page not drawn properly if sync in progress
Summary: 6.2 Beta2 - Sync Status page not drawn properly if sync in progress
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.2.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: Roman Plevka
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: Regression, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-16 04:01 UTC by Geoff Gatward
Modified: 2019-04-01 20:27 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-27 11:43:41 UTC


Attachments (Terms of Use)
sync_status - error (93.57 KB, image/png)
2016-06-22 13:16 UTC, Roman Plevka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 15499 None None None 2016-06-22 16:03 UTC

Description Geoff Gatward 2016-06-16 04:01:25 UTC
Possibly related to BZ 1315610

Navigating to the Sync Status page after a sync has been started results in a page that is not working properly:
- Unable to click any of the links (Expand All, Collapse All, Select None, Select All)
- Checking the 'Active only' box only ticks the box, no change to the page is performed
- All expand/collapse icons on the left side of the page for each section are missing
- Progress bar for in-progress syncs is missing
- Dynamic update of progress status isn't happening

Refreshing the page does not fix the issue, but results in the errors seen in BZ 1315610.

Refreshing the page after all sync tasks have completed results in the sync status page being drawn properly and functions as expected - until a sync is triggered, and then it breaks the page.

Was working in 6.2.0 Beta1, broken in Beta2.

Comment 1 Mike McCune 2016-06-16 22:20:18 UTC
We should re-test this once the fix for this bz lands:

https://bugzilla.redhat.com/show_bug.cgi?id=1315610

if that fixes this bug, we can close this one out as a dupe.

Comment 4 Walden Raines 2016-06-17 20:18:54 UTC
(In reply to Mike McCune from comment #1)
> We should re-test this once the fix for this bz lands:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1315610
> 
> if that fixes this bug, we can close this one out as a dupe.

This is most likely a dupe because I realized that the progress bar was missing while I was fixing this because of missing assets.  The fix for bug #1315610 should also fix this.

Comment 5 Bryan Kearney 2016-06-20 17:36:53 UTC
I am moving this to to ON_QA. Please test once SNAP 17.0 is released. It will contain https://bugzilla.redhat.com/show_bug.cgi?id=1315610

Comment 6 Roman Plevka 2016-06-22 13:15:34 UTC
FAILED QA:
sat6.2.0 beta (GA17.0)

There are no CSS errors, however the issue described still persists.
(see attached screenshot).

The webbrowser console shows a javascript error ("TypeError: t.attr is not a function")

Comment 7 Roman Plevka 2016-06-22 13:16 UTC
Created attachment 1170747 [details]
sync_status - error

Comment 8 Walden Raines 2016-06-22 14:40:13 UTC
(In reply to Roman Plevka from comment #6)
> FAILED QA:
> sat6.2.0 beta (GA17.0)
> 
> There are no CSS errors, however the issue described still persists.
> (see attached screenshot).
> 
> The webbrowser console shows a javascript error ("TypeError: t.attr is not a
> function")

Note that this only happens in Firefox and is unrelated to the initial cause of this bug.

Comment 9 Roman Plevka 2016-06-22 14:51:22 UTC
(In reply to Walden Raines from comment #8)

> Note that this only happens in Firefox and is unrelated to the initial cause of this bug.

Not true. Getting this error also in 
Chrome Version 51.0.2704.84 (64-bit)

However, the error is gone as soon as the Sync is complete and the page renders correctly again

Comment 10 Walden Raines 2016-06-22 15:16:01 UTC
(In reply to Roman Plevka from comment #9)
> (In reply to Walden Raines from comment #8)
> 
> > Note that this only happens in Firefox and is unrelated to the initial cause of this bug.
> 
> Not true. Getting this error also in 
> Chrome Version 51.0.2704.84 (64-bit)
> 
> However, the error is gone as soon as the Sync is complete and the page
> renders correctly again

After further discussion on IRC it became clear that this error only happens when you reload the page while a sync is running.

Comment 11 Walden Raines 2016-06-22 15:42:20 UTC
Created redmine issue http://projects.theforeman.org/issues/15499 from this bug

Comment 12 Walden Raines 2016-06-22 15:54:14 UTC
PR: https://github.com/Katello/katello/pull/6143

Comment 13 Bryan Kearney 2016-06-22 18:17:52 UTC
Upstream bug component is WebUI

Comment 14 Walden Raines 2016-06-22 22:18:51 UTC
Revision 43ddadae
Added by Walden Raines about 6 hours ago

Fixes #15499: fix JS error on sync management page.

There was a JS error on the sync management page that was causing
the page to break. This fixes the JS error by putting the HREF on
the element as was originally intended.

http://projects.theforeman.org/issues/15499

Revision eb6fda2b
Added by Walden Raines about 2 hours ago

Merge pull request #6143 from waldenraines/15499

Fixes #15499: fix JS error on sync management page.

Comment 15 Roman Plevka 2016-06-30 14:21:16 UTC
VERIFIED
on sat6.2.0 snap18.1

-the page now renders correctly with no errors in the console.

Comment 16 Bryan Kearney 2016-07-27 11:43:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.