Bug 1315622 - Missing unit in "PS_Scavenge - Collection Time per Minute" graph in JBoss ON UI
Missing unit in "PS_Scavenge - Collection Time per Minute" graph in JBoss ON UI
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 7 (Show other bugs)
JON 3.3.5
Unspecified Unspecified
medium Severity medium
: DR01
: One-off release
Assigned To: Michael Burman
Filip Brychta
: Triaged
: 1315624 (view as bug list)
Depends On: 1315624
Blocks: 1314853
  Show dependency treegraph
 
Reported: 2016-03-08 04:15 EST by bkramer
Modified: 2016-06-06 14:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1315633 (view as bug list)
Environment:
Last Closed: 2016-06-06 14:57:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot showing graph without unit (66.59 KB, image/png)
2016-03-08 04:15 EST, bkramer
no flags Details

  None (edit)
Description bkramer 2016-03-08 04:15:59 EST
Created attachment 1134077 [details]
screen shot showing graph without unit

Description of problem:

According to the JBoss ON documentation [1], graph "PS_Scavenge - Collection Time per Minute" (see attached screen shot) shows the approximate accumulated collection elapsed time in milliseconds. However, this unit (ms) is not shown in the graph




Version-Release number of selected component (if applicable):
JBoss ON 3.3.5

How reproducible:
Always

Steps to Reproduce:
1. In JBoss ON UI -> EAP standalone resource -> Server Configuration -> platform-mbean -> garbage-collector -> Garbage Collector Resources -> PS_Scavenge -> Monitoring -> Schedules 
2. Set/enable "Collection Time per Minute" metric;
3. Navigate to Monitoring -> Metrics page for this resource
4. Open the graph

Actual results:
Graph is shown without unit (ms)

Expected results:
Graph containing unit


Additional info:



[1] https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.3/html-single/Complete_Resource_Reference/index.html#JBossAS7-JBossAS7_Standalone_Server-JVM-Garbage_Collector
Comment 1 Michael Burman 2016-03-08 05:06:03 EST
Fixed in the master:

ommit b30b5e76b01918374dfed446a0dcc0770a542c66
Author: Michael Burman <miburman@redhat.com>
Date:   Tue Mar 8 12:05:04 2016 +0200

    [BZ 1315622] Add missing units to plugin descriptor for collection-time
Comment 2 Michael Burman 2016-03-08 05:11:12 EST
*** Bug 1315624 has been marked as a duplicate of this bug. ***
Comment 5 Filip Brychta 2016-03-23 05:51:26 EDT
Verified on update04 DR01

Note You need to log in before you can comment on or make changes to this bug.