This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1315666 - Data Tiering:tier volume status shows as in-progress on all nodes of a cluster even if the node is not part of volume
Data Tiering:tier volume status shows as in-progress on all nodes of a cluste...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: ZStream
Depends On: 1283957
Blocks: 1268895 1316808 1347509
  Show dependency treegraph
 
Reported: 2016-03-08 06:53 EST by hari gowtham
Modified: 2016-06-17 02:48 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283957
: 1316808 1347509 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:59:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-08 06:56:48 EST
REVIEW: http://review.gluster.org/13647 (Tier: displaying status only one the nodes running tierd) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2016-03-08 14:06:47 EST
REVIEW: http://review.gluster.org/13647 (Tier: displaying status only one the nodes running tierd) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2016-03-10 10:21:02 EST
COMMIT: http://review.gluster.org/13647 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 537822d7eb7732f2f65300668355b6d7db448f39
Author: hari gowtham <hgowtham@redhat.com>
Date:   Tue Mar 8 17:22:35 2016 +0530

    Tier: displaying status only one the nodes running tierd
    
    When tier status is given on a cluster where one node doesn't
    have tierd running, the status is shown as not started.
    
    The status of the node without tierd should not be displayed.
    
    This patch will skip if the current node if the status is not
    started
    
    Change-Id: Ibeb39f13133f94a5869b020c5ccd9bd6992323f1
    BUG: 1315666
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/13647
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Vijay Bellur 2016-04-28 10:16:23 EDT
REVIEW: http://review.gluster.org/14106 (Tier/glusterd: Resetting the tier status value to not started during volume restart and tier start force on the nodes where tierd is not supposed to run.) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 5 Vijay Bellur 2016-04-29 03:26:55 EDT
REVIEW: http://review.gluster.org/14106 (Tier/glusterd: Resetting the tier status value to not started) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 6 Vijay Bellur 2016-05-02 03:57:34 EDT
REVIEW: http://review.gluster.org/14106 (Tier/glusterd: Resetting the tier status value to not started) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 7 Vijay Bellur 2016-05-02 07:29:46 EDT
REVIEW: http://review.gluster.org/14106 (Tier/glusterd: Resetting the tier status value to not started) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 8 Vijay Bellur 2016-05-03 02:48:02 EDT
REVIEW: http://review.gluster.org/14106 (Tier/glusterd: Resetting the tier status value to not started) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 9 Vijay Bellur 2016-05-04 02:18:20 EDT
REVIEW: http://review.gluster.org/14106 (Tier/glusterd: Resetting the tier status value to not started) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 10 Vijay Bellur 2016-05-04 02:30:05 EDT
REVIEW: http://review.gluster.org/14106 (Tier/glusterd: Resetting the tier status value to not started) posted (#7) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 11 Vijay Bellur 2016-05-04 05:49:18 EDT
REVIEW: http://review.gluster.org/14106 (Tier/glusterd: Resetting the tier status value to not started) posted (#8) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 12 Vijay Bellur 2016-05-05 02:31:04 EDT
REVIEW: http://review.gluster.org/14106 (Tier/glusterd: Resetting the tier status value to not started) posted (#9) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 13 Vijay Bellur 2016-05-05 05:35:12 EDT
REVIEW: http://review.gluster.org/14106 (Tier/glusterd: Resetting the tier status value to not started) posted (#10) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 14 Vijay Bellur 2016-05-05 10:45:57 EDT
COMMIT: http://review.gluster.org/14106 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 3f07e9324d8fa62a6231f387270d8e7559ac71e0
Author: hari <hgowtham@redhat.com>
Date:   Thu Apr 28 19:36:25 2016 +0530

    Tier/glusterd: Resetting the tier status value to not started
    
    Problem: during a volume restart or tier start force, the
    value of tier status is set as started irrespective of the result.
    
    Fix: The appropriate value of status is set during the restart of
    rebalance function.
    
    Change-Id: I6164f0add48542a57dee059e80fa0f9bb036dbef
    BUG: 1315666
    Signed-off-by: hari <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/14106
    Tested-by: mohammed rafi  kc <rkavunga@redhat.com>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 15 Niels de Vos 2016-06-16 09:59:45 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.