Bug 1316808 - Data Tiering:tier volume status shows as in-progress on all nodes of a cluster even if the node is not part of volume
Data Tiering:tier volume status shows as in-progress on all nodes of a cluste...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.8
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: Reopened, ZStream
Depends On: 1283957 1315666 1347509
Blocks: 1268895
  Show dependency treegraph
 
Reported: 2016-03-11 03:09 EST by hari gowtham
Modified: 2016-06-28 08:13 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1315666
Environment:
Last Closed: 2016-06-28 08:13:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-11 03:11:05 EST
REVIEW: http://review.gluster.org/13676 (Tier: displaying status only one the nodes running tierd) posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2016-03-22 05:07:43 EDT
COMMIT: http://review.gluster.org/13676 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit ef46724375bb83f59d165d61f45e5dc10e223699
Author: hari gowtham <hgowtham@redhat.com>
Date:   Tue Mar 8 17:22:35 2016 +0530

    Tier: displaying status only one the nodes running tierd
    
            back-port of : http://review.gluster.org/#/c/13647/2
    
    When tier status is given on a cluster where one node doesn't
    have tierd running, the status is shown as not started.
    
    The status of the node without tierd should not be displayed.
    
    This patch will skip if the current node if the status is not
    started
    
    >Change-Id: Ibeb39f13133f94a5869b020c5ccd9bd6992323f1
    >BUG: 1315666
    >Signed-off-by: hari gowtham <hgowtham@redhat.com>
    
    Change-Id: I15399db6bcdea68c0a7bebcf113329d37def6e1d
    BUG: 1316808
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/13676
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 02:59:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 4 Vijay Bellur 2016-05-05 13:19:25 EDT
REVIEW: http://review.gluster.org/14229 (Tier/glusterd: Resetting the tier status value to not started) posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 5 Vijay Bellur 2016-05-05 23:43:33 EDT
COMMIT: http://review.gluster.org/14229 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 09d4a110141394fab8fcc8498e498545e7d805bf
Author: hari <hgowtham@redhat.com>
Date:   Thu Apr 28 19:36:25 2016 +0530

    Tier/glusterd: Resetting the tier status value to not started
    
            back-port of : http://review.gluster.org/#/c/14106/
    
    Problem: during a volume restart or tier start force, the
    value of tier status is set as started irrespective of the result.
    
    Fix: The appropriate value of status is set during the restart of
    rebalance function.
    
    >Change-Id: I6164f0add48542a57dee059e80fa0f9bb036dbef
    >BUG: 1315666
    >Signed-off-by: hari <hgowtham@redhat.com>
    
    Change-Id: Ie4345bd7ce1d458574e36b70fe8994b3d758396a
    BUG: 1316808
    Signed-off-by: hari <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/14229
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 6 Kaushal 2016-06-28 08:13:55 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.