Bug 131568 - modprobe seems to be broken by /etc/modprobe.conf.dist and will not load modules
modprobe seems to be broken by /etc/modprobe.conf.dist and will not load modules
Status: CLOSED DUPLICATE of bug 131441
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-02 08:41 EDT by Xander D Harkness
Modified: 2016-06-07 18:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xander D Harkness 2004-09-02 08:41:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
I upgraded modules-init-tools and rebooted and rc.sysinit when trying
to load modules modprobe fails to load any modules.

The system will boot to runlevel 1 and if i modprobe any modules I get
a failure and the top two lines of  /etc/modprobe.conf.dist printed.

When I removed the file /etc/modprobe.conf.dist the system booted normally

Version-Release number of selected component (if applicable):
module-init-tools-3.1-0.pre5.1

How reproducible:
Always

Steps to Reproduce:
1. Provide the file /etc/modprobe.conf.dist and reboot
2. The system will fail when trying modprobe and will either fail to
boot or will boot with about 5 modules loaded
3. 
    

Actual Results:  The system fails to boot and worse with the latest
kernel (kernel-2.6.8-1.538) the screen output is blank

Expected Results:  The system should boot normally into any runlevel

Additional info:

The end of afgetc(0x98cf130)                                         
                     = '\n'
realloc(0x98cf2b8, 29)                                               
         = 0x98cf2b8
puts("alias binfmt-204 binfmt_aout" <unfinished ...>
SYS_write(1, "alias binfmt-204 binfmt_aout\n", 29)                   
         = 29
<... puts resumed> )                                                 
         = 29
strspn("alias binfmt-204 binfmt_aout", "\t ")                        
         = 0
__strsep_g(0xfef6d478, 0x805424d, 29, 0x98cf298, 0x8054273)          
         = 0x98cf2b8
strspn("binfmt-204 binfmt_aout", "\t ")                              
         = 0
__strsep_g(0xfef6d478, 0x805424d, 29, 0x98cf2b8, 0x98cf2be)          
         = 0x98cf2be
strspn("binfmt_aout", "\t ")                                         
         = 0
__strsep_g(0xfef6d478, 0x805424d, 29, 0x98cf2b8, 0x98cf2be)          
         = 0x98cf2c9
fnmatch("binfmt_204",
"EOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOFEOF"...,
0 <unfinished ...>
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++
n ltrace trying to use modprobe:
Comment 1 Bill Nottingham 2004-09-02 15:49:03 EDT

*** This bug has been marked as a duplicate of 131441 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.