Bug 1315682 - libsmbios-2.3.3 is available
libsmbios-2.3.3 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libsmbios (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: srinivas gowda
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 07:18 EST by Upstream Release Monitoring
Modified: 2017-12-11 09:13 EST (History)
9 users (show)

See Also:
Fixed In Version: libsmbios-2.3.3-1.fc27
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-17 11:42:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (5.29 KB, patch)
2016-07-09 08:29 EDT, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (5.29 KB, patch)
2016-10-31 18:35 EDT, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (5.29 KB, patch)
2016-10-31 20:23 EDT, Upstream Release Monitoring
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2016-03-08 07:18:21 EST
Latest upstream release: 2.3.0
Current version/release in rawhide: 2.2.28-16.fc25
URL: http://linux.dell.com/cgi-bin/cgit.cgi/libsmbios.git/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2016-03-08 07:18:31 EST
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-20YLlI/libsmbios.spec
return code:  22
stdout:
Getting http://linux.dell.com/libsmbios/download/libsmbios/libsmbios-2.3.0/libsmbios-2.3.0.tar.bz2 to ./libsmbios-2.3.0.tar.bz2

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 2 Upstream Release Monitoring 2016-03-08 10:35:49 EST
gunnersrini's libsmbios-2.3.0-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=743028
Comment 3 Upstream Release Monitoring 2016-03-09 14:03:49 EST
pjones's libsmbios-2.3.0-2.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=743436
Comment 4 Upstream Release Monitoring 2016-07-09 08:29:00 EDT
Latest upstream release: 2.3.1
Current version/release in rawhide: 2.3.0-2.fc25
URL: http://linux.dell.com/cgi-bin/cgit.cgi/libsmbios.git/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/1727/
Comment 5 Upstream Release Monitoring 2016-07-09 08:29:18 EDT
Patching or scratch build for libsmbios-2.3.0 failed.
Comment 6 Upstream Release Monitoring 2016-07-09 08:29:20 EDT
Created attachment 1177860 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 7 Upstream Release Monitoring 2016-07-09 08:29:22 EDT
Patches were not touched. All were applied properly
Comment 8 pj 2016-10-31 11:32:04 EDT
Any chance to get the 2.3.1 into testing? Dell has updated their DSU product and breaks the smbios-utils-python-2.2.X piece. This is needed for both el6 and el7 at least, please.
Updating:
 libsmbios                x86_64         2.3.1-2193.9883.el6           dell-system-update_dependent         1.4 M
 smbios-utils-bin         x86_64         2.3.1-2193.9883.el6           dell-system-update_dependent         106 k

Transaction Summary
==================================================================================================================
Upgrade       2 Package(s)

Total size: 1.5 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libsmbios = 0:2.2.26-3.el6 is needed by (installed) python-smbios-2.2.26-3.el6.x86_64
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
python-smbios-2.2.26-3.el6.x86_64 has missing requires of libsmbios = ('0', '2.2.26', '3.el6')
Comment 9 Upstream Release Monitoring 2016-10-31 18:34:54 EDT
Latest upstream release: 2.3.2
Current version/release in rawhide: 2.3.0-3.fc25
URL: https://github.com/dell/libsmbios

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/1727/
Comment 10 Upstream Release Monitoring 2016-10-31 18:35:15 EDT
Patching or scratch build for libsmbios-2.3.0 failed.
Comment 11 Upstream Release Monitoring 2016-10-31 18:35:17 EDT
Created attachment 1215934 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 12 Upstream Release Monitoring 2016-10-31 18:35:20 EDT
Patches were not touched. All were applied properly
Comment 13 Upstream Release Monitoring 2016-10-31 20:23:35 EDT
Latest upstream release: v2.3.2
Current version/release in rawhide: 2.3.0-3.fc25
URL: https://github.com/dell/libsmbios

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/1727/
Comment 14 Upstream Release Monitoring 2016-10-31 20:23:54 EDT
Patching or scratch build for libsmbios-2.3.0 failed.
Comment 15 Upstream Release Monitoring 2016-10-31 20:23:56 EDT
Created attachment 1215958 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 16 Upstream Release Monitoring 2016-10-31 20:23:58 EDT
Following patches has been deleted:
['lis-1.5.60-optflags.patch']
Comment 17 pj 2016-11-01 07:44:49 EDT
It looks like the older 2.3.0 still continues to be built instead of the 2.3.3 version according to the attachments from the bug like:
https://bugzilla.redhat.com/attachment.cgi?id=1215958
Comment 18 pj 2016-11-01 07:46:43 EDT
Sorry that should be version 2.3.2 not 2.3.3.
Comment 19 pj 2016-11-08 08:12:47 EST
Do you need a person to test an install? Just wondering if I can help move this forward.
Comment 20 pj 2016-11-11 12:33:30 EST
To all:
Do you need a person to test an install? Just wondering if I can help move this forward.
Comment 21 pj 2016-11-17 07:30:38 EST
To all:
Do you need a person to test an install? Just wondering if I can help move this forward.
Comment 22 Upstream Release Monitoring 2017-03-14 08:16:20 EDT
Latest upstream release: 2.3.3
Current version/release in rawhide: 2.3.0-4.fc26
URL: https://github.com/dell/libsmbios

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/1727/
Comment 23 Upstream Release Monitoring 2017-03-14 08:16:24 EDT
An unexpected error occured creating the scratch build: please report this issue to the-new-hotness issue tracker at https://github.com/fedora-infra/the-new-hotness/issues
Comment 24 James A. Feister 2017-10-08 15:15:06 EDT
This package is looking abandoned.


Installation of smbios fails because it is looking for python-ctypes, which seems to be installed as part of the python-2.7 package.  Because of that it is blocking the install of the firmware-addon-dell package.  https://bugzilla.redhat.com/show_bug.cgi?id=1423565

There is also the issue that this is now three releases behind 2.3.3, which was released over 6 months ago.
Comment 25 Jiri Kastner 2017-11-01 12:12:39 EDT
@srinivas, can you please give me commit rights?

i have pull request with fixes for latest fedora and updated version:
https://src.fedoraproject.org/rpms/libsmbios/pull-request/1
Comment 26 srinivas gowda 2017-11-01 12:21:17 EDT
(In reply to Jiri Kastner from comment #25)
> @srinivas, can you please give me commit rights?
> 
> i have pull request with fixes for latest fedora and updated version:
> https://src.fedoraproject.org/rpms/libsmbios/pull-request/1

Adding Prabhakar to help you with this.
Comment 27 Fedora Update System 2017-11-15 19:50:44 EST
libsmbios-2.3.3-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c776007d0e
Comment 28 Fedora Update System 2017-11-17 11:42:25 EST
libsmbios-2.3.3-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.