Bug 1315703 - Strange build failure (rc 2 not in success_codes)
Strange build failure (rc 2 not in success_codes)
Status: CLOSED DUPLICATE of bug 1312820
Product: Copr
Classification: Community
Component: backend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 07:39 EST by clime
Modified: 2016-03-08 15:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 15:30:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description clime 2016-03-08 07:39:41 EST
This build (of copr-frontend) failed on all chroots: https://copr.fedorainfracloud.org/coprs/g/copr/copr-dev/build/166544/

The next build on the same sources executed about 20 minutes later succeeded: https://copr.fedorainfracloud.org/coprs/g/copr/copr-dev/build/166549/
(it was run only on chroot 'fedora-23-x86_64' though)

The only (for me) noticeable error in the logs (mockhain.log) for the first build is:
[2016-03-08 12:12:32,462][ ERROR][PID:23074] builder.build error building pkg `copr-frontend`: BuildError: rc 2 not in success_codes; return code: 2; stdout: starting logfile: None
Comment 1 Miroslav Suchý 2016-03-08 15:30:14 EST
The relevant part is:

WARNING: unable to delete selinux filesystems (/tmp/mock-selinux-plugin.eh9atqan): [Errno 1] Operation not permitted: '/tmp/mock-selinux-plugin.eh9atqan'

*** This bug has been marked as a duplicate of bug 1312820 ***

Note You need to log in before you can comment on or make changes to this bug.