Bug 1315752 - [lazy sync] Switching from on_demand to immediate download policy after syncing does not download files
[lazy sync] Switching from on_demand to immediate download policy after synci...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: 6.2.3
: --
Assigned To: David Davis
jcallaha
https://pulp.plan.io/issues/1778
: Triaged
: 1318334 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 09:16 EST by Justin Sherrill
Modified: 2017-10-25 18:43 EDT (History)
14 users (show)

See Also:
Fixed In Version: pulp-2.8.7.1-1
Doc Type: Bug Fix
Doc Text:
Previously, after syncing, switching download policies from on demand to immediate caused automatic downloading to stop. With this release, users can switch between download policies without any interruption to content downloads.
Story Points: ---
Clone Of:
: 1486277 (view as bug list)
Environment:
Last Closed: 2016-10-26 08:25:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 1778 High CLOSED - CURRENTRELEASE Switching a repository to immediate from on_demand doesn't download its packages 2016-05-17 16:01 EDT

  None (edit)
Description Justin Sherrill 2016-03-08 09:16:07 EST
Version-Release number of selected component (if applicable):
6.2.0 snap1

How reproducible:
always

Steps to Reproduce:
1.  Create a yum repo with the on_demand download policy
2.  Sync the repo
3.  Switch the download policy to immediate
4.  Sync the repo

Actual results:
None of the rpms are downloaded


Expected results:
Rpms get downloaded to disk


Additional info:
switching from on demand to 'background' and syncing does cause them to be synced in the background.
Comment 3 pulp-infra@redhat.com 2016-03-23 15:30:31 EDT
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.
Comment 4 pulp-infra@redhat.com 2016-03-23 15:30:33 EDT
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.
Comment 5 pulp-infra@redhat.com 2016-03-24 08:00:25 EDT
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.
Comment 6 pulp-infra@redhat.com 2016-03-31 07:03:46 EDT
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.
Comment 7 David Davis 2016-04-20 15:41:20 EDT
*** Bug 1318334 has been marked as a duplicate of this bug. ***
Comment 8 pulp-infra@redhat.com 2016-04-26 19:04:20 EDT
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.
Comment 9 pulp-infra@redhat.com 2016-05-06 13:30:53 EDT
The Pulp upstream bug status is at VERIFIED. Updating the external tracker on this bug.
Comment 10 pulp-infra@redhat.com 2016-05-17 16:01:19 EDT
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.
Comment 12 jcallaha 2016-10-11 14:52:27 EDT
Verified in Satellite 6.2.3 Snap 2.

Switching repos from both on_demand and background download policies to immediate now work appropriately.
Comment 14 errata-xmlrpc 2016-10-26 08:25:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2108
Comment 15 Andrew Dahms 2017-10-04 20:38:18 EDT
Updated 'Doc Type'.

Note You need to log in before you can comment on or make changes to this bug.