Bug 1315808 - Gluster Domain is either partially accessible or entirely inaccessible
Gluster Domain is either partially accessible or entirely inaccessible
Status: CLOSED WONTFIX
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.17.23
x86_64 Linux
unspecified Severity high (vote)
: ovirt-3.6.6
: ---
Assigned To: Tal Nisan
Aharon Canan
:
Depends On: 1269768 1311317
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 11:21 EST by Charlie Inglese
Modified: 2016-03-21 08:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 08:43:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
/var/log/vdsm.log (4.02 MB, text/plain)
2016-03-08 11:21 EST, Charlie Inglese
no flags Details
answer file (2.18 KB, text/plain)
2016-03-09 09:40 EST, Charlie Inglese
no flags Details

  None (edit)
Description Charlie Inglese 2016-03-08 11:21:06 EST
Created attachment 1134243 [details]
/var/log/vdsm.log

Description of problem:
After stand-up of initial oVirt node, VDSM error messages are seen on oVirt UI denoting domain is either inaccessible or partially inaccessible.

Version-Release number of selected component (if applicable):
vdsm-4.17.23-0.el7.centos.noarch
vdsm-cli-4.17.23-0.el7.centos.noarch
vdsm-gluster-4.17.23-0.el7.centos.noarch
vdsm-hook-vmfex-dev-4.17.23-0.el7.centos.noarch
vdsm-infra-4.17.23-0.el7.centos.noarch
vdsm-jsonrpc-4.17.23-0.el7.centos.noarch
vdsm-python-4.17.23-0.el7.centos.noarch
vdsm-xmlrpc-4.17.23-0.el7.centos.noarch
vdsm-yajsonrpc-4.17.23-0.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install oVirt 3.6.3
2. Note the oVirt UI and vdsm.log, ERROR is thrown

Actual results:
1. ERROR noted in oVirt UI and VDSM log.

Expected results:
1. No error

Additional info:
Comment 1 Tal Nisan 2016-03-09 05:06:40 EST
Ala, as this week's QE contact please have a look
Comment 2 Ala Hino 2016-03-09 07:10:08 EST
Can you please share more info regarding what you did:
Storage domain(s) you created
When did you start seeing this error?
Can you access the storage domain and make sure it is accessible?
Comment 3 Charlie Inglese 2016-03-09 09:40:07 EST
I'm attaching the answerfile that was used for the non-interactive installation.

The storage domains that were created are:
- CRITICAL
- NONCRITICAL
- REPOS
- ISODATASTORE
- cpce_bd_storage (engine domain)
Comment 4 Charlie Inglese 2016-03-09 09:40 EST
Created attachment 1134554 [details]
answer file
Comment 5 Ala Hino 2016-03-10 07:56:25 EST
These errors indicate that the storage is not accessible.
Can you verify that the storage is accessible?
Comment 6 Charlie Inglese 2016-03-10 08:59:46 EST
It appears that this issue is related to Bug 1269768. I found the following error in the ovirt-engine log:

2016-03-10 08:41:12,444 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.HSMGetStorageDomainInfoVDSCommand] (org.ovirt.thread.pool-8-thread-41) [] FINISH, HSMGetStorageDomainInfoVDSCommand, return: <StorageDomainStatic:{name='cpce_bd_storage', id='7fa61429-4fcc-4f1a-bc03-62e8210acec2'}, null>, log id: 23f4591c

We are deploying oVirt in a multiple host environment, but due to Bug 1311317, we are using OVEHOSTED_STORAGE/storageDomainName=str:cpce_bd_storage, not OVEHOSTED_STORAGE/storageDomainName=str:hosted_storage to allow us to currently add additional oVirt hosts.

Due to the fact that the hosted engine cannot auto-import its engine storage domain, we are seeing this issue.

The engine domain was accessible via NFS/Gluster from the first oVirt host. Performing a "showmount -e" displayed "engine" as an accessible mount point. However, when I tried importing that domain into oVirt, the hosted engine crashed.
Comment 7 Yaniv Lavi (Dary) 2016-03-21 08:43:34 EDT
We don't support this currently, you can do:
engine-config -s HostedEngineStorageDomainName=custom_he_storage_domain_name
service restart ovirt-engine

See BZ 1303716. You can open RFE to support this.

Note You need to log in before you can comment on or make changes to this bug.