Bug 1315811 - Any `dnf` command ends immediately with "Aborted" => broken Fedora
Any `dnf` command ends immediately with "Aborted" => broken Fedora
Status: CLOSED DUPLICATE of bug 1314592
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
: 1316121 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 11:26 EST by Jehan
Modified: 2016-04-21 04:53 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 04:53:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of running brother official printer installer. (38.71 KB, text/plain)
2016-03-08 11:26 EST, Jehan
no flags Details
Output of `journalctl --boot` (275.42 KB, text/x-vhdl)
2016-03-08 11:33 EST, Jehan
no flags Details
crash dump of rpm (904.00 KB, application/x-core)
2016-03-14 09:12 EDT, renda
no flags Details
dnf log - last installed package and deps (9.16 KB, text/plain)
2016-04-15 05:22 EDT, aqgq
no flags Details

  None (edit)
Description Jehan 2016-03-08 11:26:20 EST
Created attachment 1134245 [details]
Output of running brother official printer installer.

Description of problem:

After trying to install the driver from our printer Brother MFC-J6920DW, by running the official script from Brother, we managed to "break" Fedora:

- The system runs and I can still ssh to it (or login locally one a TTY), but the desktop does not run. We get a black screen with the mouse working, and that's it.
- Any dnf or rpm command ends immediately with either "Aborted" or "Aborted (core dumped)".

I notice that glibc i696 had been installed so thought it might be a problem. But checking another computer with Fedora 23 which installed the same script, I could confirm it also had glibc for i686 alongside glibc for x86_64 and it works fine.
In any case, I cannot uninstall (or install) anything anymore. Both dnf or rpm crash immediately with "Aborted" (134).
Attached is the console output when I ran Brother installer script.

Note that this computer was very recently reinstalled from scratch with Fedora 23. And it used to have Fedora 23 again before, and at the time, the same script had worked fine to install this printer (without breaking Fedora).
Comment 1 Jehan 2016-03-08 11:33 EST
Created attachment 1134246 [details]
Output of `journalctl --boot`
Comment 2 Jehan 2016-03-09 12:39:10 EST
Ok so on IRC, #fedora-devel, nobody had an idea and since I needed the computer, I reinstalled already. I redid the brother printer rpm installation, but this time I had my system totally up-to-date. This is the only thing yesterday which I could think of as being a potential problem.
And well, this time, it installed fine.

So since I can't really diagnose much anymore after a clean reinstallation, unless you can find anything relevant in previous logs, I guess you may close the bug report if you want. If you have any question and still want to diagnose what could have been the problem, you can ask and I will try to get information as much as I can from a fresh installation.
Thanks.
Comment 3 Dan Beard 2016-03-10 08:01:37 EST
Same issue here, but problem occurred while installing GIMP and dependencies.   Fresh F23 install.

Any yum or yum-deprecated or dnf command at all aborts and core dumps.
Comment 4 Jehan 2016-03-10 08:51:30 EST
If I am not the only case, this is definitely a big problem. Because a distribution without working package management is essentially broken. We can't even revert any past action.
Comment 5 renda 2016-03-10 23:04:04 EST
I guess this issue caused by ABI inconsistency between rpm/dnf and dependent libraries.
To avoid this problem, update all rpm-related packages before install any packages.

I had same issue when I installed canon's printer driver, 
and I could recover my environment with following procedure.
1. Boot from F23 install disk
2. Open the console on tty1
3. Mount root filesystem to /mnt/tmp
4. cp -r /mnt/tmp/etc/yum.repos.d /etc
5. dnf --installroot=/mnt/tmp --releasever=23 update
6. chroot /mnt/tmp /usr/bin/rpm , and it works
Comment 6 Honza Silhan 2016-03-14 08:59:36 EDT
(In reply to renda from comment #5)
> I guess this issue caused by ABI inconsistency between rpm/dnf and dependent
> libraries.

Then probably it could be in library rpm use (according to Dan, yum-deprecated was broken too). Does it core dumped during rpm transaction? Can you attach core dump file, please?
Comment 7 Michal Luscon 2016-03-14 09:08:54 EDT
*** Bug 1316121 has been marked as a duplicate of this bug. ***
Comment 8 renda 2016-03-14 09:12 EDT
Created attachment 1136141 [details]
crash dump of rpm
Comment 9 Honza Silhan 2016-03-21 08:55:39 EDT
Thanks, we'll take a look.
Comment 10 fred.the.fish 2016-03-22 04:49:06 EDT
Same thing happening to me after trying to install Skype from the Fedora 32-bit RPM. I briefly tried to debug the problem but gdb also seems to be affected - gdb now also aborts in the same way. Please let me know if you want any core dumps or logs.
Comment 11 Slava 2016-03-23 02:49:02 EDT
Same here  after installing team viewer. Glibc i686 got installed and anything python 3.4 related got killed.


[root@desk01 ~]# dnf clean all
Aborted (core dumped)

[root@desk01 ~]# rpm 
Aborted (core dumped)


Mar 23 02:48:02 desk01 abrt-hook-ccpp: Process 10046 (abrt-action-save-package-data) of user 0 killed by SIGABRT - ignoring ('DebugLevel' == 0)
Mar 23 02:48:02 desk01 abrt-server: 'post-create' on '/var/spool/abrt/ccpp-2016-03-23-02:47:57-10032' exited with 134
Mar 23 02:48:02 desk01 abrt-server: Deleting problem directory '/var/spool/abrt/ccpp-2016-03-23-02:47:57-10032'
Mar 23 02:48:02 desk01 audit: ANOM_ABEND auid=4294967295 uid=988 gid=982 ses=4294967295 subj=system_u:system_r:setroubleshootd_t:s0-s0:c0.c1023 pid=10044 comm="setroubleshootd" exe="/usr/bin/python3.4" sig=6
Mar 23 02:48:02 desk01 abrt-hook-ccpp: Process 10044 (python3.4) of user 988 killed by SIGABRT - dumping core
Mar 23 02:48:02 desk01 audit: AVC avc:  denied  { getattr } for  pid=10049 comm="abrt-hook-ccpp" path="ipc:[4026531839]" dev="
Comment 12 AdamS 2016-03-23 15:01:05 EDT
I got this error as well after installing glibc.i686

However this was not immediate, i was still able to do a dnf search then i left the server for a week when i went on vacation.  When i got back i tried doing an update for dnf and got "Aborted (core dumped)".

Here is what the specific version of the server 
"4.3.5-300.fc23.x86_64 #1 SMP Mon Feb 1 03:18:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux"

I did just set up a virtual machine and did a dnf install of glibc.i686 and did a search and it still was fine, but so was the other one right after even after 2 reboots.  It also could be because this VM of Fedora 23 is a higher version
"4.4.5-300.fc23.x86_64 #1 SMP Thu Mar 10 17:54:44 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux"

I've tried a bunch of stuff to get it working but both rpm and dnf abort.


when trying to run dnf update
******************************
[root@parachute ~]# dnf update
Aborted (core dumped)

/var/log/messages
*****************
Mar 23 13:58:45 parachute audit: ANOM_ABEND auid=0 uid=0 gid=0 ses=1 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=19738 comm="dnf" exe="/usr/bin/python3.4" sig=6
Mar 23 13:58:45 parachute abrt-hook-ccpp: Process 19738 (python3.4) of user 0 killed by SIGABRT - dumping core
Mar 23 13:58:45 parachute audit: ANOM_ABEND auid=4294967295 uid=0 gid=0 ses=4294967295 subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 pid=19742 comm="abrt-action-sav" exe="/usr/bin/abrt-action-save-package-data" sig=6
Mar 23 13:58:45 parachute abrt-hook-ccpp: Process 19742 (abrt-action-save-package-data) of user 0 killed by SIGABRT - ignoring ('DebugLevel' == 0)
Mar 23 13:58:45 parachute abrt-server: 'post-create' on '/var/spool/abrt/ccpp-2016-03-23-13:58:45-19738' exited with 134


when trying to run rpm
***********************
[root@parachute ~]# rpm
Aborted (core dumped)

/var/log/messages
*****************
Mar 23 14:00:27 parachute audit: ANOM_ABEND auid=0 uid=0 gid=0 ses=1 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=19745 comm="rpm" exe="/usr/bin/rpm" sig=6
Mar 23 14:00:27 parachute abrt-hook-ccpp: Process 19745 (rpm) of user 0 killed by SIGABRT - dumping core
Mar 23 14:00:27 parachute audit: ANOM_ABEND auid=4294967295 uid=0 gid=0 ses=4294967295 subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 pid=19749 comm="abrt-action-sav" exe="/usr/bin/abrt-action-save-package-data" sig=6
Mar 23 14:00:27 parachute abrt-hook-ccpp: Process 19749 (abrt-action-save-package-data) of user 0 killed by SIGABRT - ignoring ('DebugLevel' == 0)
Mar 23 14:00:27 parachute abrt-server: 'post-create' on '/var/spool/abrt/ccpp-2016-03-23-14:00:27-19745' exited with 134


hopefully a resolution is found quickly,
thanks
Comment 13 Jehan 2016-03-23 15:20:09 EDT
Is there a way to get the history of installed packages (which packages and in which order) without access to `dnf` or `rpm`? I'm guessing this could help to reproduce the problem.
Comment 14 AdamS 2016-03-23 16:22:39 EDT
I did a history of my commands which show what i manually installed after installing from the disc.

http://pastebin.com/3rwe63d3

maybe this will help
Comment 15 Andrej 2016-03-25 15:48:58 EDT
The same problem here: dnf and rpm are not working. Output is "Aborted (core dumped)".

It's a fresh installation of F23 (from LiveKDE,x86_64) and the problem appeared after installing 32-bit packages for 32-bit Skype (the procedure is described here [1])

Installed packages:
alsa-lib.i686 fontconfig.i686 freetype.i686 glib2.i686 libSM.i686 libXScrnSaver.i686 libXi.i686 libXrandr.i686 libXrender.i686 libXv.i686 libstdc++.i686 pulseaudio-libs.i686 qt.i686 qt-x11.i686 zlib.i686 qtwebkit.i686

This is really a major issue because one cannot even repair anything from the system without the package manager.

[1] http://www.if-not-true-then-false.com/2012/install-skype-on-fedora-centos-red-hat-rhel-scientific-linux-sl/
Comment 16 Gergely Polonkai 2016-04-14 04:40:30 EDT
I have the same problem with the problem of I can’t boot from an install disk (my machine is a DigitalOcean droplet to which I cannot insert any medium).
Comment 17 aqgq 2016-04-14 08:22:14 EDT
Same here. Was working on a F23. I've installed cmake, then a glibc-devel.i686 and yum/dnf stopped working. Just getting the "Aborted (core dumped)" information. However, I would not point to cmake installation since after it I've managed to install glibc with dependencies. I believe the latter installation caused the issue.
Comment 18 aqgq 2016-04-15 05:22 EDT
Created attachment 1147556 [details]
dnf log - last installed package and deps

Last successfully installation log
Comment 19 Gergely Polonkai 2016-04-15 08:20:02 EDT
dnf log also aborts for me. One more thing to add on my side: I have no i686 packages installed (as others pointed to that as the possible source of the problem)
Comment 20 MarkRuff 2016-04-16 06:11:41 EDT
I also have the problem right after installing glibc.i686
Comment 21 charles.unix.pro 2016-04-19 22:11:35 EDT
Observations:

I installed glibc.i686; 'dnf' and 'rpm' no longer work.

Running 'rpm' generates a core file:

    core.977: ELF 64-bit LSB core file x86-64, version 1 (SYSV), too many program headers (277)

'strace rpm':

    open("/dev/urandom", O_RDONLY)          = 3
    read(3, "&\36\26K\2672Q\360\"\372n\331\35\30\357\337\33\254\200P\377\254\364P\243<H\354\244?Gu"..., 1024) = 1024
    close(3)                                = 0
    rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
    tgkill(913, 913, SIGABRT)               = 0
    --- SIGABRT {si_signo=SIGABRT, si_code=SI_TKILL, si_pid=913, si_uid=1000} ---
    +++ killed by SIGABRT (core dumped) +++
    Abort (core dumped)

gdb rpm?

    Reading symbols from rpm...Abort (core dumped)

ld.so?

    setenv LD_DEBUG all
    rpm
    ...
       994:         object=/lib64/libnspr4.so [0]
       994:          scope 0: rpm /lib64/librpm.so.7 /lib64/librpmio.so.7 /lib64/libcap.so.2 /lib64/libacl.so.1 /lib64/libdb-5.3.so /lib64/libbz2.so.1 /lib64/libelf.so.1 /lib64/liblzma.so.5 /lib64/liblua-5.3.so /lib64/libm.so.6 /lib64/libnss3.so /lib64/libpopt.so.0 /lib64/libz.so.1 /lib64/libdl.so.2 /lib64/libpthread.so.0 /lib64/libc.so.6 /lib64/libattr.so.1 /lib64/ld-linux-x86-64.so.2 /lib64/libnssutil3.so /lib64/libplc4.so /lib64/libplds4.so /lib64/libnspr4.so /lib64/librt.so.1
    ...
       994:         opening file=/lib64/libnspr4.so [0]; direct_opencount=1
       994:
       994:         symbol=PR_Free;  lookup in file=/lib64/libnspr4.so [0]
       994:         binding file /lib64/libnspr4.so [0] to /lib64/libnspr4.so [0]: normal symbol `PR_Free'
       994:         symbol=PR_Open;  lookup in file=/lib64/libnspr4.so [0]
       994:         binding file /lib64/libnspr4.so [0] to /lib64/libnspr4.so [0]: normal symbol `PR_Open'
       994:         symbol=PR_ImportPipe;  lookup in file=/lib64/libnspr4.so [0]
    ...
       994:         symbol=PR_DestroyLock;  lookup in file=/lib64/libnspr4.so [0]
       994:         binding file /lib64/libnspr4.so [0] to /lib64/libnspr4.so [0]: normal symbol `PR_DestroyLock'
       994:         symbol=PR_GetEnvSecure;  lookup in file=/lib64/libnspr4.so [0]
       994:         symbol=PR_GetEnvSecure;  lookup in file=/lib64/libpthread.so.0 [0]
       994:         symbol=PR_GetEnvSecure;  lookup in file=/lib64/libdl.so.2 [0]
       994:         symbol=PR_GetEnvSecure;  lookup in file=/lib64/librt.so.1 [0]
       994:         symbol=PR_GetEnvSecure;  lookup in file=/lib64/libc.so.6 [0]
       994:         symbol=PR_GetEnvSecure;  lookup in file=/lib64/ld-linux-x86-64.so.2 [0]
       994:         /lib64/libnspr4.so: error: symbol lookup error: undefined symbol: PR_GetEnvSecure (fatal)
       994:
       994:         closing file=/lib64/libnspr4.so; direct_opencount=0


Investigating PR_GetEnvSecure takes us to https://bugzilla.redhat.com/show_bug.cgi?id=1314592

-- Charles
Comment 22 charles.unix.pro 2016-04-19 22:43:01 EDT
Okay, I have a workaround that seems to restore functionality.

I copied /lib64/libnspr4.so from a machine with nspr-4.12.0-1.fc23.x86_64 to the broken machine, did a ldconfig and a reboot.

rpm and dnf no longer crash.

-- Charles
Comment 23 Gergely Polonkai 2016-04-20 03:07:17 EDT
Workaround for comment #22 works for me (even without a reboot, but I guess it’s better to do it).
Comment 24 Michal Luscon 2016-04-21 04:53:03 EDT
Ok, closing as a duplicate of #1314592. If there is anything else for the further discussion, feel free to reopen.

*** This bug has been marked as a duplicate of bug 1314592 ***

Note You need to log in before you can comment on or make changes to this bug.