Bug 1315835 - kcalc Doesn't start (with Qt 5.6)
kcalc Doesn't start (with Qt 5.6)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kcalc (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
: 1319737 (view as bug list)
Depends On:
Blocks: qt-5.6
  Show dependency treegraph
 
Reported: 2016-03-08 12:57 EST by Rex Dieter
Modified: 2016-03-29 19:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: kcalc-15.12.3-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 13:59:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 360105 None None None 2016-03-08 12:57 EST

  None (edit)
Description Rex Dieter 2016-03-08 12:57:22 EST
kcalc fails to start (with Qt 5.6), seems to be some sort of deadlock (dbus)?

While apparently hung, gdb reports:

Thread 3 (Thread 0x7f8118e42700 (LWP 28639)):
#0  0x00007f81316f0fdd in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f812f651272 in _xcb_conn_wait (__timeout=-1, __nfds=1, __fds=0x7f8118e41b80) at /usr/include/bits/poll2.h:46
#2  0x00007f812f651272 in _xcb_conn_wait (c=c@entry=0x5569a8b12b20, cond=cond@entry=0x5569a8b12b60, vector=vector@entry=0x0, count=count@entry=0x0) at xcb_conn.c:459
#3  0x00007f812f652ee7 in xcb_wait_for_event (c=0x5569a8b12b20) at xcb_in.c:693
#4  0x00007f811b2a3349 in QXcbEventReader::run() (this=0x5569a8b1d2f0) at qxcbconnection.cpp:1313
#5  0x00007f813257ae18 in QThreadPrivate::start(void*) (arg=0x5569a8b1d2f0) at thread/qthread_unix.cpp:340
#6  0x00007f812f43160a in start_thread (arg=0x7f8118e42700) at pthread_create.c:334
#7  0x00007f81316fca4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f8112870700 (LWP 28640)):
#0  0x00007f81316f0fdd in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f812eee916c in g_main_context_iterate (priority=2147483647, n_fds=3, fds=0x7f810c003020, timeout=<optimized out>, context=0x7f810c000990) at gmain.c:4135
#2  0x00007f812eee916c in g_main_context_iterate (context=context@entry=0x7f810c000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3835
#3  0x00007f812eee927c in g_main_context_iteration (context=0x7f810c000990, may_block=may_block@entry=1) at gmain.c:3901
#4  0x00007f81327a3cef in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f810c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f813274c6ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f811286fc50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f8132576004 in QThread::exec() (this=this@entry=0x7f813550b040 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:503
#7  0x00007f8135497445 in QDBusConnectionManager::run() (this=0x7f813550b040 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:181
#8  0x00007f813257ae18 in QThreadPrivate::start(void*) (arg=0x7f813550b040 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:340
#9  0x00007f812f43160a in start_thread (arg=0x7f8112870700) at pthread_create.c:334
#10 0x00007f81316fca4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f812274e940 (LWP 28635)):
#0  0x00007f81316f0fdd in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f812eee916c in g_main_context_iterate (priority=2147483647, n_fds=2, fds=0x5569a8f48200, timeout=<optimized out>, context=0x7f81140016f0) at gmain.c:4135
#2  0x00007f812eee916c in g_main_context_iterate (context=context@entry=0x7f81140016f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3835
#3  0x00007f812eee927c in g_main_context_iteration (context=0x7f81140016f0, may_block=may_block@entry=1) at gmain.c:3901
#4  0x00007f81327a3cef in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x5569a8b3db60, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f813274c6ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffdb31f6a10, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f8132754ddc in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1285
#7  0x00007f8132f950dc in QGuiApplication::exec() () at kernel/qguiapplication.cpp:1598
#8  0x00007f813357ec35 in QApplication::exec() () at kernel/qapplication.cpp:2973
#9  0x00007f81350f4871 in kdemain(int, char**) (argc=1, argv=<optimized out>) at /usr/src/debug/kcalc-15.12.1/kcalc.cpp:2324
#10 0x00007f813161a580 in __libc_start_main (main=
    0x5569a768a9a0 <main(int, char**)>, argc=1, argv=0x7ffdb31f6d68, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffdb31f6d58)
    at libc-start.c:289
#11 0x00005569a768a9d9 in _start ()
Comment 1 Rex Dieter 2016-03-08 13:01:14 EST
hrm, to rule out glib event loop, here's when running with QT_NO_GLIB=1

Thread 3 (Thread 0x7fd75967f700 (LWP 28730)):
#0  0x00007fd771f31fdd in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fd76fe92272 in _xcb_conn_wait (__timeout=-1, __nfds=1, __fds=0x7fd75967eb80) at /usr/include/bits/poll2.h:46
#2  0x00007fd76fe92272 in _xcb_conn_wait (c=c@entry=0x563176076b20, cond=cond@entry=0x563176076b60, vector=vector@entry=0x0, count=count@entry=0x0) at xcb_conn.c:459
#3  0x00007fd76fe93ee7 in xcb_wait_for_event (c=0x563176076b20) at xcb_in.c:693
#4  0x00007fd75bae0349 in QXcbEventReader::run() (this=0x5631760812f0) at qxcbconnection.cpp:1313
#5  0x00007fd772dbbe18 in QThreadPrivate::start(void*) (arg=0x5631760812f0) at thread/qthread_unix.cpp:340
#6  0x00007fd76fc7260a in start_thread (arg=0x7fd75967f700) at pthread_create.c:334
#7  0x00007fd771f3da4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fd75320c700 (LWP 28731)):
#0  0x00007fd771f33d63 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fd772fe055f in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) (nfds=10, fdread=fdread@entry=0x7fd74c000a78, fdwrite=fdwrite@entry=0x7fd74c000d08, fdexcept=fdexcept@entry=0x7fd74c000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007fd772fe1f9e in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) (timeout=0x0, exceptfds=0x7fd74c000f98, writefds=0x7fd74c000d08, readfds=0x7fd74c000a78, nfds=<optimized out>, this=0x7fd74c0008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  0x00007fd772fe1f9e in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) (this=this@entry=0x7fd74c0008e0, flags=..., 
    flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007fd772fe24b2 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fd74c0008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007fd772f8d6ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fd75320bc50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fd772db7004 in QThread::exec() (this=this@entry=0x7fd775d48040 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:503
#7  0x00007fd775cd4445 in QDBusConnectionManager::run() (this=0x7fd775d48040 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:181
#8  0x00007fd772dbbe18 in QThreadPrivate::start(void*) (arg=0x7fd775d48040 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:340
#9  0x00007fd76fc7260a in start_thread (arg=0x7fd75320c700) at pthread_create.c:334
#10 0x00007fd771f3da4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fd762f8b940 (LWP 28726)):
#0  0x00007fd771f33d63 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fd772fe055f in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) (nfds=7, fdread=fdread@entry=0x5631760bc988, fdwrite=fdwrite@entry=0x5631760bcc18, fdexcept=fdexcept@entry=0x5631760bcea8, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007fd772fe1f9e in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) (timeout=0x0, exceptfds=0x5631760bcea8, writefds=0x5631760bcc18, readfds=0x5631760bc988, nfds=<optimized out>, this=0x5631760af5b0) at kernel/qeventdispatcher_unix.cpp:320
#3  0x00007fd772fe1f9e in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) (this=this@entry=0x5631760bc7f0, flags=..., 
    flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007fd772fe24b2 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x5631760af5b0, flags=flags@entry=...)
    at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007fd75bb5260d in QUnixEventDispatcherQPA::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=<optimized out>, flags=...)
    at eventdispatchers/qunixeventdispatcher.cpp:62
#6  0x00007fd772f8d6ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffc58ff92f0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007fd772f95ddc in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1285
---Type <return> to continue, or q <return> to quit---
#8  0x00007fd7737d60dc in QGuiApplication::exec() () at kernel/qguiapplication.cpp:1598
#9  0x00007fd773dbfc35 in QApplication::exec() () at kernel/qapplication.cpp:2973
#10 0x00007fd775935871 in kdemain(int, char**) (argc=1, argv=<optimized out>) at /usr/src/debug/kcalc-15.12.1/kcalc.cpp:2324
#11 0x00007fd771e5b580 in __libc_start_main (main=
    0x56317486b9a0 <main(int, char**)>, argc=1, argv=0x7ffc58ff9648, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc58ff9638)
    at libc-start.c:289
#12 0x000056317486b9d9 in _start ()
Comment 2 Rex Dieter 2016-03-16 09:27:34 EDT
 %changelog
+* Wed Mar 16 2016 Rex Dieter <rdieter@fedoraproject.org> 15.12.3-2
+- workaround kcalc size issue on Qt-5.6 (#1315835,kde#360105)
Comment 3 Jan Grulich 2016-03-22 11:36:18 EDT
*** Bug 1319737 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2016-03-22 16:17:57 EDT
ark-15.12.3-1.fc24 filelight-15.12.3-1.fc24 kcalc-15.12.3-2.fc24 kcharselect-15.12.3-1.fc24 kde-print-manager-15.12.3-1.fc24 kdebugsettings-15.12.3-1.fc24 kdf-15.12.3-1.fc24 kfloppy-15.12.3-1.fc24 kgpg-15.12.3-1.fc24 kremotecontrol-15.12.3-1.fc24 kteatime-15.12.3-1.fc24 ktimer-15.12.3-1.fc24 kwalletmanager5-15.12.3-1.fc24 sweeper-15.12.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-17edd3399f
Comment 5 Fedora Update System 2016-03-22 16:20:57 EDT
filelight-15.12.3-1.fc23 kcalc-15.12.3-2.fc23 kcharselect-15.12.3-1.fc23 kde-print-manager-15.12.3-1.fc23 kdebugsettings-15.12.3-1.fc23 kdf-15.12.3-1.fc23 kfloppy-15.12.3-1.fc23 kgpg-15.12.3-1.fc23 kremotecontrol-15.12.3-1.fc23 kteatime-15.12.3-1.fc23 ktimer-15.12.3-1.fc23 kwalletmanager5-15.12.3-1.fc23 sweeper-15.12.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-56aaf22158
Comment 6 Fedora Update System 2016-03-23 21:53:17 EDT
filelight-15.12.3-1.fc23, kcalc-15.12.3-2.fc23, kcharselect-15.12.3-1.fc23, kde-print-manager-15.12.3-1.fc23, kdebugsettings-15.12.3-1.fc23, kdf-15.12.3-1.fc23, kfloppy-15.12.3-1.fc23, kgpg-15.12.3-1.fc23, kremotecontrol-15.12.3-1.fc23, kteatime-15.12.3-1.fc23, ktimer-15.12.3-1.fc23, kwalletmanager5-15.12.3-1.fc23, sweeper-15.12.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-56aaf22158
Comment 7 Fedora Update System 2016-03-26 13:59:42 EDT
ark-15.12.3-1.fc24, filelight-15.12.3-1.fc24, kcalc-15.12.3-2.fc24, kcharselect-15.12.3-1.fc24, kde-print-manager-15.12.3-1.fc24, kdebugsettings-15.12.3-1.fc24, kdf-15.12.3-1.fc24, kfloppy-15.12.3-1.fc24, kgpg-15.12.3-1.fc24, kremotecontrol-15.12.3-1.fc24, kteatime-15.12.3-1.fc24, ktimer-15.12.3-1.fc24, kwalletmanager5-15.12.3-1.fc24, sweeper-15.12.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-03-29 19:20:12 EDT
filelight-15.12.3-1.fc23, kcalc-15.12.3-2.fc23, kcharselect-15.12.3-1.fc23, kde-print-manager-15.12.3-1.fc23, kdebugsettings-15.12.3-1.fc23, kdf-15.12.3-1.fc23, kfloppy-15.12.3-1.fc23, kgpg-15.12.3-1.fc23, kremotecontrol-15.12.3-1.fc23, kteatime-15.12.3-1.fc23, ktimer-15.12.3-1.fc23, kwalletmanager5-15.12.3-1.fc23, sweeper-15.12.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.