Bug 1291040 - (qt-5.6) qt-5.6.0 tracker
qt-5.6.0 tracker
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt5-qtbase (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Tracking
Depends On: 1290020 1291073 1292098 1311635 1315835 1322393
Blocks: 1227295 1291003 1313811
  Show dependency treegraph
 
Reported: 2015-12-12 21:50 EST by Rex Dieter
Modified: 2016-06-28 07:36 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-28 07:36:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2015-12-12 21:50:20 EST
Tracking bug for Qt 5.6.0 related issues
Comment 1 Edward O 2015-12-29 06:18:44 EST
As mentioned in 1291003, qt-5.6-beta fixes the infamous screen issues affecting qt/plasma/kscreen/... ( upstream https://bugreports.qt.io/browse/QTBUG-42985 )

a) Do you plan on providing fedora 23 test builds sometime soon ? I see builds for rawhide already but can't install them on 23 without upgrading half of the system too ;-)

b) Will qt 5.6 eventually reach F23 stable, or
c) do you want plan on backporting these fixes to qt 5.5 instead (apparently upstream won't make any further qt 5.5 release)
Comment 2 Rex Dieter 2015-12-29 09:54:25 EST
a.  Test builds are availble in copr,

https://copr.fedoraproject.org/coprs/g/kdesig/Qt5/

b.  yes, once 5.6.0 is formally released and continued testing goes well

c.  most likely no, only if b doesn't happen
Comment 3 Bernie Innocenti 2016-02-23 13:52:30 EST
Any updates on (b)? I'm still experiencing regular crashes on F23 when hot-plugging monitors.
Comment 4 Rex Dieter 2016-02-23 13:55:13 EST
https://wiki.qt.io/Qt-5.6-release

Feb 23 -- Release Candidate
Mar 3 -- Final Release


https://copr.fedorainfracloud.org/coprs/g/kdesig/Qt5

is being updated to the RC release now.
Comment 5 Chris Hubick 2016-03-18 10:50:10 EDT
Installed this build from copr attempting to escape bug 1313811, and also just triggered bug 1278002 after powering on my UHD TV (connected to a GTX 980 with the proprietary driver) and unlocking the screen.
Comment 6 Rex Dieter 2016-03-18 12:36:40 EDT
ok, looks like the crash moved higher in the stack (which is good)
Comment 7 Rex Dieter 2016-06-28 07:36:41 EDT
5.6.0 is deployed everywhere , closing.

We're tracking 5.6.1 now in bug #1347385

Note You need to log in before you can comment on or make changes to this bug.