This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1315876 - Clicking content view url from Dashboard -> 'Content View History' results in url redirect loop
Clicking content view url from Dashboard -> 'Content View History' results in...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Dashboard (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: Brad Buckingham
Roman Plevka
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 15:50 EST by sthirugn@redhat.com
Modified: 2016-07-27 07:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:04:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14185 None None None 2016-04-22 12:42 EDT

  None (edit)
Description sthirugn@redhat.com 2016-03-08 15:50:49 EST
Description of problem:
Clicking content view url from Dashboard -> 'Content View History' results in url redirect loop

Version-Release number of selected component (if applicable):
Satellite 6.2.0-beta-snap2.1

How reproducible:
Always

Steps to Reproduce:
1. Publish and promote few content views
2. Navigate to Monitor -> Dashboard
3. Click on any content view url in `Content View History` widget

Actual results:
The url results in url redirect loop as it is trying to access:
https://$sat6host/content_views/2/versions/3

Expected results:
Perhaps the url should access https://$sat6host/content_views/2/versions/3/details which works fine without a url redirect loop

Additional info:
Comment 2 Brad Buckingham 2016-03-14 10:06:05 EDT
Created redmine issue http://projects.theforeman.org/issues/14185 from this bug
Comment 3 Brad Buckingham 2016-03-14 10:09:20 EDT
Katello PR:  https://github.com/Katello/katello/pull/5876
Comment 4 Roman Plevka 2016-03-23 08:08:09 EDT
I believe the other root cause of this bug aside the invalid page link might be:
https://bugzilla.redhat.com/show_bug.cgi?id=1320516 - which causes URL redirect loops on invalid url subpaths for all katello instances.
Comment 6 Roman Plevka 2016-05-16 05:13:59 EDT
VERIFIED

sat 6.2.0 Beta GA11

- widget now refers to the correct path so no redirection loop happens, However the root cause persists. Since this is covered in another BZ, I'm putting this one to Verified
Comment 7 Bryan Kearney 2016-07-27 07:04:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.